码迷,mamicode.com
首页 > 编程语言 > 详细

1025 PAT Ranking[排序][一般]

时间:2018-08-07 20:33:27      阅读:239      评论:0      收藏:0      [点我收藏+]

标签:ace   ++   sample   list   ranking   str   number   tar   ble   

1025 PAT Ranking (25)(25 分)

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (<=100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (<=300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:

9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

 题目大意:将多个考场中的考生按分数排序,输出格式是:id,最终排名,所属考场,考场排名。

AC代码:

#include <cstdio>
#include<iostream>
#include <string.h>
#include<algorithm>

using namespace std;
struct Stu{
    string id;
    int lno,lrank,fin,score;
}stu[30000];
bool cmp(Stu& a, Stu& b){
    if(a.score>b.score)return true;
    else if(a.score==b.score) {
        if(a.id<b.id) return true;
        else return false;
    }
    return false;
}
int main() {
   int n,m;
   cin>>n;
   string s;
   int score,ct=0;
   for(int i=0;i<n;i++){
        cin>>m;
        for(int j=0;j<m;j++){
            cin>>s>>score;
            stu[ct].id=s;
            stu[ct].lno=i+1;
            stu[ct++].score=score;
        }
        sort(stu+ct-m,stu+ct,cmp);
        stu[ct-m].lrank=1;
        int p=2;
        for(int j=ct-m+1;j<ct;j++){
            stu[j].lrank=p++;
            if(stu[j].score==stu[j-1].score)
                stu[j].lrank=stu[j-1].lrank;
        }
//        for(int j=ct-m;j<ct;j++){
//            cout<<stu[j].id<<" "<<stu[j].fin<<" "<<stu[j].lno<<" "<<stu[j].lrank<<‘\n‘;
//        }
   }
    sort(stu,stu+ct,cmp);
    stu[0].fin=1;
    for(int i=1;i<ct;i++){
        stu[i].fin=i+1;
        if(stu[i].score==stu[i-1].score)
            stu[i].fin=stu[i-1].fin;
    }
    cout<<ct<<\n;
    for(int i=0;i<ct;i++){
        cout<<stu[i].id<<" "<<stu[i].fin<<" "<<stu[i].lno<<" "<<stu[i].lrank<<\n;
    }
    return 0;
}

 

1.提交了四五次。

2.更加深入理解了sort函数,第一个参数是起点,第二个参数是终点,第三个是排序函数。注意第二个不是排序长度,而是指向排序终点的下一个。 

3.提交时一定要把自己的中间输出给注释掉。

4.还要注意在排序时有相同的数怎么办,这个是在大神代码里学到的。

 

1025 PAT Ranking[排序][一般]

标签:ace   ++   sample   list   ranking   str   number   tar   ble   

原文地址:https://www.cnblogs.com/BlueBlueSea/p/9438899.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!