码迷,mamicode.com
首页 > 其他好文 > 详细

PAT 甲级 1081 Rational Sum (数据不严谨 点名批评)

时间:2018-08-08 22:56:21      阅读:227      评论:0      收藏:0      [点我收藏+]

标签:code   start   [1]   isp   alc   follow   ret   mina   lin   

https://pintia.cn/problem-sets/994805342720868352/problems/994805386161274880

 

Given N rational numbers in the form "numerator/denominator", you are supposed to calculate their sum.

Input Specification:

Each input file contains one test case. Each case starts with a positive integer N (<=100), followed in the next line N rational numbers "a1/b1 a2/b2 ..." where all the numerators and denominators are in the range of "long int". If there is a negative number, then the sign must appear in front of the numerator.

Output Specification:

For each test case, output the sum in the simplest form "integer numerator/denominator" where "integer" is the integer part of the sum, "numerator" < "denominator", and the numerator and the denominator have no common factor. You must output only the fractional part if the integer part is 0.

Sample Input 1:

5
2/5 4/15 1/30 -2/60 8/3

Sample Output 1:

3 1/3

Sample Input 2:

2
4/3 2/3

Sample Output 2:

2

Sample Input 3:

3
1/3 -1/6 1/8

Sample Output 3:

7/24

代码:
#include <bits/stdc++.h>
using namespace std;

long long a[111], b[111];
long long sum, m;

long long gcd(long long x, long long y) {
    long long z = x % y;
    while(z) {
        x = y;
        y = z;
        z = x % y;
    }
    return y;
}

long long ad(long long x, long long y) {
    if(x > y)
        swap(x, y);
    if(y % x == 0)
        return y;
    else
        return x * y / gcd(x, y);
}

void display(long long p, long long q) {
    if(q == 0 || p == 0)
        printf("0\n");
    else {
        bool flag = true;
        if(p < 0) {
            flag = false;
            printf("-");
            p = abs(p);
        }

        if(p / q != 0) {
            if(p % q == 0)
                printf("%lld\n", p / q);
            else {
                long long mm = p / q;
                printf("%lld ", mm);
                if(!flag) cout << "-";
                printf("%lld/%lld", (p - mm * q) / gcd(p - mm * q, q), q / gcd(p - mm * q, q));
            }
        } else {
            printf("%lld/%lld", p / gcd(p, q), q / gcd(p, q));
          }

    }
}

void add(long long x, long long y) {
    //  sum / m + x / y
    // = (sum * y + m * x) / (x * y);
    long long xx = sum * y + m * x;
    long long yy = m * y;
    long long g = gcd(abs(xx), abs(yy));
    xx /= g;
    yy /= g;
    sum = xx;
    m = yy;
}

int main() {

    int N;
    scanf("%d", &N);
    for(int i = 1; i <= N; i ++)
        scanf("%lld/%lld", &a[i], &b[i]);

    if(N == 0) {
        printf("0\n");
        return 0;
    }
    if(N ==1) {
        display(a[1], b[1]);
        return 0;
    }

/*
    long long m = ad(b[1], b[2]);
    for(int i = 3; i <= N; i ++) {
        m = ad(m, b[i]);
    }

    long long sum = 0;
    for(int i = 1; i <= N; i ++) {
        sum += a[i] * m / b[i];
    }
*/
    sum = a[1];
    m = b[1];
    for(int i = 2; i <= N; i ++) {
        add(a[i], b[i]);
    }

    if(m < 0) {
        sum = -sum;
        m = -m;
    }
    display(sum, m);

    return 0;
}

  

PAT 甲级 1081 Rational Sum (数据不严谨 点名批评)

标签:code   start   [1]   isp   alc   follow   ret   mina   lin   

原文地址:https://www.cnblogs.com/zlrrrr/p/9446173.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!