码迷,mamicode.com
首页 > 其他好文 > 详细

PAT 1030 Travel Plan[图论][难]

时间:2018-08-09 21:15:04      阅读:114      评论:0      收藏:0      [点我收藏+]

标签:contain   ati   enc   amp   cas   res   ber   不能   限制   

1030 Travel Plan (30)(30 分)

A traveler‘s map gives the distances between cities along the highways, together with the cost of each highway. Now you are supposed to write a program to help a traveler to decide the shortest path between his/her starting city and the destination. If such a shortest path is not unique, you are supposed to output the one with the minimum cost, which is guaranteed to be unique.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 4 positive integers N, M, S, and D, where N (<=500) is the number of cities (and hence the cities are numbered from 0 to N-1); M is the number of highways; S and D are the starting and the destination cities, respectively. Then M lines follow, each provides the information of a highway, in the format:

City1 City2 Distance Cost

where the numbers are all integers no more than 500, and are separated by a space.

Output Specification:

For each test case, print in one line the cities along the shortest path from the starting point to the destination, followed by the total distance and the total cost of the path. The numbers must be separated by a space and there must be no extra space at the end of output.

Sample Input

4 5 0 3
0 1 1 20
1 3 2 30
0 3 4 10
0 2 2 20
2 3 1 20

Sample Output

0 2 3 3 40

 题目大意:给出起点和终点,找出起点和终点之间的所有最短路径,并且cost最小。每条边有两个属性,一个是距离,一个是花费。

// 这个就是迪杰斯特拉裸题,我一定要做出来,见过多少次这样的题了。

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
#define INF 999999
int edge[500][500];
int cost[500][500];
int dist[500],co[500];
bool vis[500];
int pre[500];
vector<int> path;
int main() {
    int n,m,s,d;
    cin>>n>>m>>s>>d;
    int f,t,e,c;
    fill(cost[0],cost[0]+500*500,INF);//二维数组必须用cost[0],而不能用cost。
    fill(edge[0],edge[0]+500*500,INF);//这么多初始化有点烦。
    for(int i=0;i<m;i++){
        cin>>f>>t>>e>>c;
        edge[f][t]=edge[t][f]=e;
        cost[f][t]=cost[t][f]=c;
    }
    fill(dist,dist+n,INF);
    fill(co,co+n,INF);
    fill(pre,pre+n,0);
   for(int i=0;i<n;i++){
        if(edge[s][i]!=0)
            dist[i]=edge[s][i];//初始化
        if(cost[s][i]!=0)
            co[i]=cost[s][i];
   }
    //选出距离s最近的点。

    dist[s]=0;
    vis[s]=true;
    pre[s]=-1;
    int u=-1,minn=INF;
    for(int i=0;i<n;i++){
        u=-1,minn=INF;
        for(int j=0;j<n;j++){
            if(!vis[j]&&dist[j]<minn){
                minn=dist[j];
                u=j;
            }
        }
        if(u==-1||u==d)break;
        vis[u]=true;
        for(int j=0;j<n;j++){
            if(!vis[j]){
                if(dist[j]>dist[u]+edge[u][j]){
                    dist[j]=dist[u]+edge[u][j];
                    pre[j]=u;
                    co[j]=co[u]+cost[u][j];
                }else if(dist[j]==dist[u]+edge[u][j]){
                    if(co[j]>co[u]+cost[u][j]){
                        pre[j]=u;
                        co[j]=co[u]+cost[u][j];
                    }
                }
            }
        }
    }
    path.push_back(d);
    u=d;
    while(pre[u]!=-1){
        path.push_back(pre[u]);
        u=pre[u];
    }//s不用再单独push了。
    for(int i=path.size()-1;i>=0;i--){
        cout<<path[i]<<" ";
    }
    cout<<dist[d]<<" "<<co[d];

    return 0;
}

 

//第一次我是这么写的,但是提示内存超限。需要改进啊。原来考点在这个地方啊,又是考内存。内存超限:您的程序使用了超过限制的内存。case通过率为30.00%

都改成了vector加上resize,也不行,也是超时。

 

PAT 1030 Travel Plan[图论][难]

标签:contain   ati   enc   amp   cas   res   ber   不能   限制   

原文地址:https://www.cnblogs.com/BlueBlueSea/p/9451503.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!