码迷,mamicode.com
首页 > 其他好文 > 详细

dfs例题

时间:2018-08-11 01:19:43      阅读:119      评论:0      收藏:0      [点我收藏+]

标签:name   with   vertica   sum   aced   next   present   most   scanf   

 

例题1:fire net


题目描述

Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall.
A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening.
Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets.
The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through.
The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways.

技术分享图片

Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration.

输入

The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a ‘.‘ indicating an open space and an uppercase ‘X‘ indicating a wall. There are no spaces in the input file.

输出

For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.

样例输入

4
.X..
....
XX..
....
2
XX
.X
3
.X.
X.X
.X.
3
...
.XX
.XX
4
....
....
....
....
0

样例输出

5
1
5
2
4


思路:
其实就是dfs一遍即可,从0,0开始dfs,每次dfs时都查看一下符不符合要求。
源码
#include<cstdio>
#include<algorithm>
using namespace std;
int ans,n;
char s[5][5];
bool check(int x,int y)
{
    for(int i=x-1;i>=0;i--)
    {
        if(s[i][y]==‘X‘)
            break;
        if(s[i][y]==‘#‘)
            return false;
    }
    for(int i=y-1;i>=0;i--)
    {
        if(s[x][i]==‘X‘)
            break;
        if(s[x][i]==‘#‘)
            return false;
    }
    return true;
}
void dfs(int position,int curr)
{
    if(position==n*n)
    {
        ans=max(ans,curr);
        return ;
    }
    int x=position/n;
    int y=position%n;
    if(s[x][y]==‘.‘ && check(x,y))
    {
        s[x][y]=‘#‘;
        dfs(position+1,curr+1);
        s[x][y]=‘.‘;
    }
    dfs(position+1,curr);
}
int main()
{
    while(scanf("%d", &n) && n!=0)
    {
        ans=0;
        for(int i=0;i<4;i++)
            for(int j=0;j<4;j++)
                s[i][j]=‘X‘;
        for(int i=0;i<n;i++)
            for(int j=0;j<n;j++)
                scanf(" %c", &s[i][j]);
        dfs(0,0);
        printf("%d\n", ans);
    }
}

 

 

dfs例题

标签:name   with   vertica   sum   aced   next   present   most   scanf   

原文地址:https://www.cnblogs.com/Wolfbeyond/p/9457895.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!