码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1200 Crazy Search

时间:2018-08-11 19:38:12      阅读:139      评论:0      收藏:0      [点我收藏+]

标签:mem   %s   lang   this   hid   not   include   idt   std   

Crazy Search
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 32337   Accepted: 8906

Description

Many people like to solve hard puzzles some of which may lead them to madness. One such puzzle could be finding a hidden prime number in a given text. Such number could be the number of different substrings of a given size that exist in the text. As you soon will discover, you really need the help of a computer and a good algorithm to solve such a puzzle. 
Your task is to write a program that given the size, N, of the substring, the number of different characters that may occur in the text, NC, and the text itself, determines the number of different substrings of size N that appear in the text. 

As an example, consider N=3, NC=4 and the text "daababac". The different substrings of size 3 that can be found in this text are: "daa"; "aab"; "aba"; "bab"; "bac". Therefore, the answer should be 5. 

Input

The first line of input consists of two numbers, N and NC, separated by exactly one space. This is followed by the text where the search takes place. You may assume that the maximum number of substrings formed by the possible set of characters does not exceed 16 Millions.

Output

The program should output just an integer corresponding to the number of different substrings of size N found in the given text.

Sample Input

3 4
daababac

Sample Output

5

Hint

Huge input,scanf is recommended.

思路:

又学会了一种求hash值的方式,这种方式只能求固定长度的hash值,优点是内存占用小

代码

#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
using namespace std;
typedef unsigned long long ll;
const int maxn = 1.6e7+5;
char a[maxn];
bool mp[maxn];
int name[300];
ll p;
int n,m;
int main()
{
    scanf("%d%d",&n,&m);
    scanf("%s",a+1);
    int len=strlen(a+1);
    int k=0;
    for(int i=1;i<=len;i++){
        if(!name[a[i]]){name[a[i]]=++k;}
        if(k==m){break;}
    }
    int ans=0;
    ll sum=0;
    p=1;
    for(int i=1;i<=n;i++){
        p*=m;
        sum=sum*m+name[a[i]];
    }
    mp[sum]=1;
    ans++;
    for(int i=n+1;i<=len;i++){
        sum=sum*m+name[a[i]]-name[a[i-n]]*p;
        if(!mp[sum]){
            ans++;
            mp[sum]=1;
        }
    }
    printf("%d\n",ans);
}

  

 

POJ 1200 Crazy Search

标签:mem   %s   lang   this   hid   not   include   idt   std   

原文地址:https://www.cnblogs.com/ZGQblogs/p/9460672.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!