码迷,mamicode.com
首页 > 其他好文 > 详细

Necklace of Beads (polya定理的引用)

时间:2018-08-13 00:48:33      阅读:166      评论:0      收藏:0      [点我收藏+]

标签:around   together   idt   line   传送门   lines   +=   produced   http   

Beads of red, blue or green colors are connected together into a circular necklace of n beads ( n < 24 ). If the repetitions that are produced by rotation around the center of the circular necklace or reflection to the axis of symmetry are all neglected, how many different forms of the necklace are there?
技术分享图片

Input
The input has several lines, and each line contains the input data n.
-1 denotes the end of the input file.
Output
The output should contain the output data: Number of different forms, in each line correspondent to the input data.
Sample Input
4
5
-1
Sample Output
21
39

模板题, 当然是直接上板子啦; 有对Polya定理不懂的小伙伴点这里 : 传送门
#include<iostream>
#include<cmath>

using namespace std;
#define ll long long

ll Pow(int value,int num)
{   __int64 sum=1;
    for(int i=1;i<=num;i++)
        sum*=value;
    return sum;
}

int gcd(int a, int b)
{
    if(b) return gcd(b, a%b);
    else return a;
}

ll polya(int col, int num)  // col 表示颜色种类, num 表示换环的长度
{
    ll sum = 0;
    for(int i = 1; i <= num; i++)
    {
        sum += Pow(col, gcd(num,i));
    }
    if(num&1) sum += num*(Pow(col, num/2+1));
    else sum += (Pow(col, num/2) + Pow(col, num/2+1))*(num/2);
    return sum/2/num;

}

int main()
{
    int n;
    while(cin >> n, n != -1)
    {
        if(n == 0) cout << 0 << endl;
        else
        {
            ll ans = polya(3,n);
            cout << ans << endl;
        }

    }
    return 0;
}

 

 

Necklace of Beads (polya定理的引用)

标签:around   together   idt   line   传送门   lines   +=   produced   http   

原文地址:https://www.cnblogs.com/mrh-acmer/p/9465553.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!