码迷,mamicode.com
首页 > 其他好文 > 详细

sicily 1009. Mersenne Composite N

时间:2014-10-05 20:19:38      阅读:278      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   color   io   os   ar   java   for   

Description
One of the world-wide cooperative computing tasks is the "Grand Internet Mersenne Prime Search" -- GIMPS -- striving to find ever-larger prime numbers by examining a particular category of such numbers. 
A Mersenne number is defined as a number of the form (2p–1), where p is a prime number -- a number divisible only by one and itself. (A number that can be divided by numbers other than itself and one are called "composite" numbers, and each of these can be uniquely represented by the prime numbers that can be multiplied together to generate the composite number — referred to as its prime factors.) 
Initially it looks as though the Mersenne numbers are all primes. 
PrimeCorresponding Mersenne Number
2 4–1 = 3 -- prime
3 8–1 = 7 -- prime
5 32–1 = 31 -- prime
7 128–1 = 127 -- prime

If, however, we are having a "Grand Internet" search, that must not be the case. 
Where k is an input parameter, compute all the Mersenne composite numbers less than 2k -- where k <= 63 (that is, it will fit in a 64-bit signed integer on the computer). In Java, the "long" data type is a signed 64 bit integer. Under gcc and g++ (C and C++ in the programming contest environment), the "long long" data type is a signed 64 bit integer. 
Input
Input is from file a. in. It contains a single number, without leading or trailing blanks, giving the value of k. As promised, k <= 63. 
Output
One line per Mersenne composite number giving first the prime factors (in increasing order) separate by asterisks, an equal sign, the Mersenne number itself, an equal sign, and then the explicit statement of the Mersenne number, as shown in the sample output. Use exactly this format. Note that all separating white space fields consist of one blank. 
Sample Input
bubuko.com,布布扣 Copy sample input to clipboard 
31
Sample Output
23 * 89 = 2047 = ( 2 ^ 11 ) - 1
47 * 178481 = 8388607 = ( 2 ^ 23 ) - 1
233 * 1103 * 2089 = 536870911 = ( 2 ^ 29 ) - 1

 

// 给定一个数 k,求小于 k 的数 p 且有 2 ^ p - 1是一个合数的数的质因子
#include <iostream>
#include <cmath>

using namespace std;

int main(int argc, char *argv[])
{
    int num;
    cin >> num;
    int p[10] = {11, 23, 29, 37, 41, 43, 47, 53, 59};
    for (int i = 0; i != 10 && p[i] < num; ++i) {
        long long result = static_cast<long long>(pow(2, p[i])) - 1;
        long long temp = result;
        long long factor = 2;

        bool flag = false;
        while (factor * factor < result) {
            if (result % factor == 0) {
                flag = true;
                result /= factor;
                cout << factor << " * ";
            } else {
                factor++;
            }
        }
        if (flag)
            cout << result << " = " << temp << " = ( 2 ^ " << p[i] << " ) - 1" << endl;
    }

    return 0;
}

 

sicily 1009. Mersenne Composite N

标签:des   style   blog   color   io   os   ar   java   for   

原文地址:http://www.cnblogs.com/xiezhw3/p/4007301.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!