码迷,mamicode.com
首页 > 其他好文 > 详细

PAT 1118 Birds in Forest

时间:2018-08-19 19:06:06      阅读:151      评论:0      收藏:0      [点我收藏+]

标签:cas   guarantee   int   output   mes   describes   rds   tis   ret   

Some scientists took pictures of thousands of birds in a forest. Assume that all the birds appear in the same picture belong to the same tree. You are supposed to help the scientists to count the maximum number of trees in the forest, and for any pair of birds, tell if they are on the same tree.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive number N (≤10^?4?? ) which is the number of pictures. Then N lines follow, each describes a picture in the format:

K B?1 B2 ... BK
??
where K is the number of birds in this picture, and Bi ‘s are the indices of birds. It is guaranteed that the birds in all the pictures are numbered continuously from 1 to some number that is no more than 104.

After the pictures there is a positive number Q (≤10^4 ) which is the number of queries. Then Q lines follow, each contains the indices of two birds.

Output Specification:
For each test case, first output in a line the maximum possible number of trees and the number of birds. Then for each query, print in a line Yes if the two birds belong to the same tree, or No if not.

Sample Input:
4
3 10 1 2
2 3 4
4 1 5 7 8
3 9 6 4
2
10 5
3 7

Sample Output:
2 10
Yes
No

#include<iostream> //并查集
#include<math.h>
#include<vector> 
using namespace std;
vector<int> birds(10010, 0), check(10010, 0);
int findfather(int b){
  int t=b;
  while(birds[b]!=b)
    b=birds[b];
  while(birds[t]!=b){
    int temp=t;
    t=birds[t];
    birds[temp]=b;
  }
  return b;
}
void Union(int a, int b){
  int m= findfather(a);
  int n= findfather(b);
  if(m!=n) birds[m]=n;
}
int main(){
  int n, k, b, num=0, cnt=0, qn;
  cin>>n;
  vector<int> picture(n, 0);
  for(int i=0; i<10010; i++)
    birds[i]=i;
  for(int i=0; i<n; i++){
    cin>>k;
    for(int j=0; j<k; j++){
      cin>>b;
      num=max(num, b);
      if(picture[i]==0)
        picture[i]=b;
      Union(b, picture[i]);
    }
  }
  for(int i=1; i<=num; i++){
    b=findfather(i);
    if(check[b]==0){
      cnt++;
      check[b]=1;
    }
  }
  cout<<cnt<<" "<<num<<endl;
  cin>>qn;
  for(int i=0; i<qn; i++){
    int a, b;
    cin>>a>>b;
    if(findfather(a)==findfather(b))
      cout<<"Yes"<<endl;
    else
      cout<<"No"<<endl;
  }
  return 0;
}

PAT 1118 Birds in Forest

标签:cas   guarantee   int   output   mes   describes   rds   tis   ret   

原文地址:https://www.cnblogs.com/A-Little-Nut/p/9502064.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!