码迷,mamicode.com
首页 > 其他好文 > 详细

hdu3949(线性基,求第k小的异或和

时间:2018-09-12 21:12:16      阅读:362      评论:0      收藏:0      [点我收藏+]

标签:ase   ssi   sea   this   use   multi   tor   contain   memset   

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=3949

XOR

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4731    Accepted Submission(s): 1658


Problem Description
XOR is a kind of bit operator, we define that as follow: for two binary base number A and B, let C=A XOR B, then for each bit of C, we can get its value by check the digit of corresponding position in A and B. And for each digit, 1 XOR 1 = 0, 1 XOR 0 = 1, 0 XOR 1 = 1, 0 XOR 0 = 0. And we simply write this operator as ^, like 3 ^ 1 = 2,4 ^ 3 = 7. XOR is an amazing operator and this is a question about XOR. We can choose several numbers and do XOR operatorion to them one by one, then we get another number. For example, if we choose 2,3 and 4, we can get 2^3^4=5. Now, you are given N numbers, and you can choose some of them(even a single number) to do XOR on them, and you can get many different numbers. Now I want you tell me which number is the K-th smallest number among them.
 

 

Input
First line of the input is a single integer T(T<=30), indicates there are T test cases.
For each test case, the first line is an integer N(1<=N<=10000), the number of numbers below. The second line contains N integers (each number is between 1 and 10^18). The third line is a number Q(1<=Q<=10000), the number of queries. The fourth line contains Q numbers(each number is between 1 and 10^18) K1,K2,......KQ.
 

 

Output
For each test case,first output Case #C: in a single line,C means the number of the test case which is from 1 to T. Then for each query, you should output a single line contains the Ki-th smallest number in them, if there are less than Ki different numbers, output -1.
 

 

Sample Input
2 2 1 2 4 1 2 3 4 3 1 2 3 5 1 2 3 4 5
 

 

Sample Output
Case #1: 1 2 3 -1 Case #2: 0 1 2 3 -1
Hint
If you choose a single number, the result you get is the number you choose. Using long long instead of int because of the result may exceed 2^31-1.
 

 

Author
elfness
 

 

Source
 

 

Recommend
xubiao   |   We have carefully selected several similar problems for you:  3946 3948 3947 3945 3944 
 
题目大意:输入t,t组样例,输入n,有n个数,接下来为n个数的值,输入q,代表q次询问,接下来q个数,要你求出第k小的数
学习:https://www.cnblogs.com/vb4896/p/6149022.html
思路:这一题显然是线性基来做,首先先把最大线性无关组,也就是线性基求出来,然后题目要求是要你求出第k小的数,在线性基的基础上,我们可以稍微改造一下,就是保证只有b[i]的第i位是1,其它的第i
位都为0,有了这个性质,我们要求第k小的数,就是把k用二进制表示,如果第j为是1的话,就异或第j个线性基的向量,这里可能需要的读者多想一下,(因为都是二进制表示,具体的我也描述不出来)
看代码:
#include<iostream>
#include<string.h>
#include<map>
#include<cstdio>
#include<cstring>
#include<stdio.h>
#include<cmath>
#include<ctype.h>
#include<math.h>
#include<algorithm>
#include<set>
#include<queue>
typedef long long ll;
using namespace std;
const ll mod=1e9+7;
const int maxn=1e4+10;
const int maxk=5e3+10;
const int maxx=1e4+10;
const ll maxe=1000+10;
#define INF 0x3f3f3f3f3f3f
#define Lson l,mid,rt<<1
#define Rson mid+1,r,rt<<1|1
ll a[maxn],b[100];
ll m,k;
void guass(int n)
{
    memset(b,0,sizeof(b));
    for(int i=0;i<n;i++)
    {
        for(int j=63;j>=0;j--)
        {
            if((a[i]>>j)&1)
            {
                if(!b[j])
                {
                    b[j]=a[i];
                    break;
                }
                else
                {
                    a[i]^=b[j];
                }
            }
        }
    }
    for(int i=63;i>=0;i--)
    {
        if(!b[i]) continue;
        for(int j=i+1;j<=63;j++)
        {
            if((b[j]>>i)&1) b[j]^=b[i];//为了使得只有b[i]的第i为1,其它的都不为1
        }
    }
    m=0;
    for(int i=0;i<=63;i++) if(b[i]) b[m++]=b[i];
}
int main()
{
    int t,ca=1,n,q;
    cin>>t;
    while(t--)
    {
        cin>>n;
        printf("Case #%d:\n",ca++);
        for(int i=0;i<n;i++)
        {
            cin>>a[i];
        }
        guass(n);
        cin>>q;
        while(q--)
        {
            ll ans=0;
            cin>>k;
            if(n!=m) k--;//代表可以是0
            if(k>=(1ll<<m)) cout<<"-1"<<endl;
            else
            {
                for(int i=0;i<=63;i++) if((k>>i)&1) ans^=b[i];
                cout<<ans<<endl;
            }
        }
    }
    return 0;
}

 

hdu3949(线性基,求第k小的异或和

标签:ase   ssi   sea   this   use   multi   tor   contain   memset   

原文地址:https://www.cnblogs.com/caijiaming/p/9637189.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!