码迷,mamicode.com
首页 > 其他好文 > 详细

PAT 1020 月饼

时间:2018-09-14 23:10:07      阅读:198      评论:0      收藏:0      [点我收藏+]

标签:using   tar   int   -o   problem   中秋   ret   its   pre   

https://pintia.cn/problem-sets/994805260223102976/problems/994805301562163200

 

月饼是中国人在中秋佳节时吃的一种传统食品,不同地区有许多不同风味的月饼。现给定所有种类月饼的库存量、总售价、以及市场的最大需求量,请你计算可以获得的最大收益是多少。

注意:销售时允许取出一部分库存。样例给出的情形是这样的:假如我们有 3 种月饼,其库存量分别为 18、15、10 万吨,总售价分别为 75、72、45 亿元。如果市场的最大需求量只有 20 万吨,那么我们最大收益策略应该是卖出全部 15 万吨第 2 种月饼、以及 5 万吨第 3 种月饼,获得 72 + 45/2 = 94.5(亿元)。

输入格式:

每个输入包含一个测试用例。每个测试用例先给出一个不超过 1000 的正整数 N 表示月饼的种类数、以及不超过 500(以万吨为单位)的正整数 D 表示市场最大需求量。随后一行给出 N 个正数表示每种月饼的库存量(以万吨为单位);最后一行给出 N 个正数表示每种月饼的总售价(以亿元为单位)。数字间以空格分隔。

输出格式:

对每组测试用例,在一行中输出最大收益,以亿元为单位并精确到小数点后 2 位。

输入样例:

3 20
18 15 10
75 72 45

输出样例:

94.50

代码:

#include <bits/stdc++.h>
using namespace std;

int N, M;

struct Goods {
    double W;
    double V;
    double money;
}goods[1010];

bool cmp(const Goods& a, const Goods& b) {
    return a.money > b.money;
}

int main() {
    scanf("%d%d", &N, &M);
    for(int i = 1; i <= N; i ++)
        cin >> goods[i].W;
    for(int i = 1; i <= N; i ++)
        cin >> goods[i].V;
    for(int i = 1; i <= N; i ++)
        goods[i].money = goods[i].V / goods[i].W;

    double res = 0.0;
    sort(goods + 1, goods + 1 + N, cmp);

    for(int i = 1; i <= N; i ++) {
        if(M >= goods[i].W) {
            res += goods[i].V;
            M -= goods[i].W;
        } else {
            res += 1.0 * M * goods[i].money;
            break;
        }
    }

    printf("%.2lf\n", res);
    return 0;
}

  

PAT 1020 月饼

标签:using   tar   int   -o   problem   中秋   ret   its   pre   

原文地址:https://www.cnblogs.com/zlrrrr/p/9649048.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!