码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1711 Number Sequence

时间:2018-09-15 16:28:21      阅读:134      评论:0      收藏:0      [点我收藏+]

标签:ext   简单   and   clu   describe   printf   des   esc   ane   

Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one. 

InputThe first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000]. 
OutputFor each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead. 
Sample Input

2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1

Sample Output

6
-1
kmp简单题。
代码:
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
int n,m;
int a[1000000],b[10000];
void findNext(int *S,int Snum,int *Next) {
    int i = 0,j = -1;
    Next[0] = -1;
    while(i < Snum) {
        if(j == -1 || S[i] == S[j]) {
            Next[++ i] = ++ j;
        }
        else j = Next[j];
    }
}
int Kmp() {
    int Next[10000],ans = 0;
    findNext(b,m,Next);
    int i = -1,j = -1;
    while(i < n) {
        if(j == -1 || a[i] == b[j]) {
            i ++,j ++;
        }
        else j = Next[j];
        if(j == m) return i - m + 1;
    }
    return -1;
}
int main() {
    int t;
    scanf("%d",&t);
    while(t --) {
        scanf("%d%d",&n,&m);
        for(int i = 0;i < n;i ++) {
            scanf("%d",&a[i]);
        }
        for(int i = 0;i < m;i ++) {
            scanf("%d",&b[i]);
        }
        printf("%d\n",Kmp());
    }
    return 0;
}

 

hdu 1711 Number Sequence

标签:ext   简单   and   clu   describe   printf   des   esc   ane   

原文地址:https://www.cnblogs.com/8023spz/p/9650962.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!