码迷,mamicode.com
首页 > 其他好文 > 详细

ACM-ICPC 2018 焦作赛区网络预赛 B题 Mathematical Curse

时间:2018-09-15 20:08:54      阅读:279      评论:0      收藏:0      [点我收藏+]

标签:which   UNC   when   string   present   ini   nat   guarantee   ati   

A prince of the Science Continent was imprisoned in a castle because of his contempt for mathematics when he was young, and was entangled in some mathematical curses. He studied hard until he reached adulthood and decided to use his knowledge to escape the castle.

There are NN rooms from the place where he was imprisoned to the exit of the castle. In the i^{th}ith room, there is a wizard who has a resentment value of a[i]a[i]. The prince has MM curses, the j^{th}jth curse is f[j]f[j], and f[j]f[j] represents one of the four arithmetic operations, namely addition(‘+‘), subtraction(‘-‘), multiplication(‘*‘), and integer division(‘/‘). The prince‘s initial resentment value is KK. Entering a room and fighting with the wizard will eliminate a curse, but the prince‘s resentment value will become the result of the arithmetic operation f[j]f[j] with the wizard‘s resentment value. That is, if the prince eliminates the j^{th}jth curse in the i^{th}ith room, then his resentment value will change from xx to (x\ f[j]\ a[i]x f[j] a[i]), for example, when x=1, a[i]=2, f[j]=x=1,a[i]=2,f[j]=‘+‘, then xx will become 1+2=31+2=3.

Before the prince escapes from the castle, he must eliminate all the curses. He must go from a[1]a[1] to a[N]a[N] in order and cannot turn back. He must also eliminate the f[1]f[1] to f[M]f[M] curses in order(It is guaranteed that N\ge MNM). What is the maximum resentment value that the prince may have when he leaves the castle?

Input

The first line contains an integer T(1 \le T \le 1000)T(1T1000), which is the number of test cases.

For each test case, the first line contains three non-zero integers: N(1 \le N \le 1000), M(1 \le M \le 5)N(1N1000),M(1M5) and K(-1000 \le K \le 1000K(?1000K1000), the second line contains NN non-zero integers: a[1], a[2], ..., a[N](-1000 \le a[i] \le 1000)a[1],a[2],...,a[N](?1000a[i]1000), and the third line contains MM characters: f[1], f[2], ..., f[M](f[j] =f[1],f[2],...,f[M](f[j]=‘+‘,‘-‘,‘*‘,‘/‘, with no spaces in between.

Output

For each test case, output one line containing a single integer.

样例输入

3
2 1 5
2 3
/
3 2 1
1 2 3
++
4 4 5
1 2 3 4
+-*/

样例输出

2
6
3

题目来源

ACM-ICPC 2018 焦作赛区网络预赛

题解:DP;

分别记录最大值和最小值,(因为可能出现两个都是负数的情况),转移方程为:

dp[i][j] = dp[i - 1][j];  dp1[i][j] = dp1[i - 1][j];分别记录最大和最小
对于不同符号,有不同的转移方程

参考代码:

#include <iostream>
#include <stdio.h>
#include <math.h>
#include <string.h>
#include <string>
#include <algorithm>
#include <bitset>
#define INF 0x3f3f3f3f3f3f3f3fll
#define clr(x, y) memset(x, y, sizeof(x))
#define mod 1000000007
using namespace std;
typedef long long LL;
const int maxn = 1010;
const int maxm = 10;
int a[maxn],t;
LL dp[maxn][maxm],dp1[maxn][maxn];
char f[maxm];
LL Max(LL a,LL b) {return a>=b? a:b; }
LL Min(LL a,LL b)  { return a<b? a:b; }
int main()
{
    scanf("%d", &t);
    while(t--)
    {
        memset(dp, -INF, sizeof dp);
        memset(dp1,INF,sizeof dp1);
        int n, m, k;
        scanf("%d%d%d", &n, &m, &k);
        for(int i = 1; i <= n; i++)
        {
            scanf("%d", &a[i]);
            dp[i][0] =dp1[i][0]=k;
        }
        dp[0][0] = dp1[0][0] = k;
        scanf("%s", f + 1);
        for(int i = 1; i <= n; i++)
        {
            for(int j = 1; j <= m; j++)
            {
            	if(i<j) continue;
                dp[i][j] = dp[i - 1][j]; dp1[i][j] = dp1[i - 1][j];
                if(f[j] == ‘+‘) dp[i][j]=Max(dp[i][j],dp[i - 1][j - 1] + a[i]), dp1[i][j]=Min(dp1[i][j],dp1[i - 1][j - 1] + a[i]);
                else if(f[j] == ‘-‘) dp[i][j] = Max(dp[i][j], dp[i - 1][j - 1] - a[i]), dp1[i][j] = Min(dp1[i][j], dp1[i - 1][j - 1] - a[i]);
                else if(f[j] == ‘*‘)
				{
					dp[i][j] = Max(dp[i][j], Max(dp[i - 1][j - 1] * a[i],dp1[i - 1][j - 1] * a[i]) );
					dp1[i][j] = Min(dp1[i][j], Min(dp[i - 1][j - 1] * a[i],dp1[i - 1][j - 1] * a[i]) );
				} 
                else 
				{
					dp[i][j] = Max(dp[i][j], Max(dp[i - 1][j - 1] / a[i], dp1[i - 1][j - 1] / a[i]) );
					dp1[i][j]=Min(dp1[i][j], Min(dp[i - 1][j - 1] / a[i], dp1[i - 1][j - 1] / a[i]) );
				}
            }
        }
        printf("%lld\n", Max(dp[n][m],dp1[n][m]) );
    }
    return 0;
}

  

ACM-ICPC 2018 焦作赛区网络预赛 B题 Mathematical Curse

标签:which   UNC   when   string   present   ini   nat   guarantee   ati   

原文地址:https://www.cnblogs.com/songorz/p/9651880.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!