码迷,mamicode.com
首页 > 其他好文 > 详细

ACM-ICPC 2018 焦作赛区网络预赛 K题 Transport Ship

时间:2018-09-15 20:51:36      阅读:362      评论:0      收藏:0      [点我收藏+]

标签:lin   define   fine   bit   ons   clu   htm   different   代码   

There are NN different kinds of transport ships on the port. The i^{th}ith kind of ship can carry the weight of V[i]V[i] and the number of the i^{th}ith kind of ship is 2^{C[i]} - 12C[i]?1. How many different schemes there are if you want to use these ships to transport cargo with a total weight of SS?

It is required that each ship must be full-filled. Two schemes are considered to be the same if they use the same kinds of ships and the same number for each kind.

Input

The first line contains an integer T(1 \le T \le 20)T(1T20), which is the number of test cases.

For each test case:

The first line contains two integers: N(1 \le N \le 20), Q(1 \le Q \le 10000)N(1N20),Q(1Q10000), representing the number of kinds of ships and the number of queries.

For the next NN lines, each line contains two integers: V[i](1 \le V[i] \le 20), C[i](1 \le C[i] \le 20)V[i](1V[i]20),C[i](1C[i]20), representing the weight the i^{th}ith kind of ship can carry, and the number of the i^{th}ith kind of ship is 2^{C[i]} - 12C[i]?1.

For the next QQ lines, each line contains a single integer: S(1 \le S \le 10000)S(1S10000), representing the queried weight.

Output

For each query, output one line containing a single integer which represents the number of schemes for arranging ships. Since the answer may be very large, output the answer modulo 10000000071000000007.

样例输入

1
1 2
2 1
1
2

样例输出

0
1

题目来源

ACM-ICPC 2018 焦作赛区网络预赛

题解:二进制求和+DP

参考代码:

#include<iostream>
#include<stdio.h>
#include<math.h>
#include<string.h>
#include<string>
#include<algorithm>
#include<bitset>
#define INF 0x3f3f3f3f
#define clr(x, y) memset(x, y, sizeof(x))
#define mod 1000000007
using namespace std;
typedef long long LL;
const int maxn=25;
const int maxm=10010;
int v[maxn],c[maxn];
LL dp[maxm];

int main()
{
    int t;
    scanf("%d", &t);
    while(t--)
    {
        int n, q;
        scanf("%d%d", &n, &q);
        memset(dp, 0, sizeof(dp));
        dp[0] = 1;
        for(int i = 1; i <= n; i++)
        {
            scanf("%d%d", &v[i], &c[i]);
            LL cur = 1;
            for(int j = 1; j <= c[i]; j++)
            {
                for(int k = 10000; k >= cur * v[i]; k--)
                    dp[k] = (dp[k] + dp[k - cur * v[i]]) % mod;
                cur<<=1;
            }
        }
        for(int i = 1; i <= q; i++)
        {
            int s;
            scanf("%d", &s);
            printf("%lld\n", dp[s]);
        }
    }
    return 0;
}

  

ACM-ICPC 2018 焦作赛区网络预赛 K题 Transport Ship

标签:lin   define   fine   bit   ons   clu   htm   different   代码   

原文地址:https://www.cnblogs.com/songorz/p/9651985.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!