码迷,mamicode.com
首页 > 其他好文 > 详细

PAT 1145 Hashing - Average Search Time

时间:2018-09-15 22:06:26      阅读:218      评论:0      收藏:0      [点我收藏+]

标签:flag   fir   which   name   eth   rom   insert   res   lin   

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table first. Then try to find another sequence of integer keys from the table and output the average search time (the number of comparisons made to find whether or not the key is in the table). The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:
Each input file contains one test case. For each case, the first line contains 3 positive numbers: MSize, N, and M, which are the user-defined table size, the number of input numbers, and the number of keys to be found, respectively. All the three numbers are no more than 10^4. Then N distinct positive integers are given in the next line, followed by M positive integer keys in the next line. All the numbers in a line are separated by a space and are no more than 10^5.

Output Specification:
For each test case, in case it is impossible to insert some number, print in a line X cannot be inserted. where X is the input number. Finally print in a line the average search time for all the M keys, accurate up to 1 decimal place.

Sample Input:

4 5 4
10 6 4 15 11
11 4 15 2

Sample Output:

15 cannot be inserted.
2.8

#include<iostream> //hash表, 平方探测
#include<vector>
using namespace std;
bool isprime(int a){
    if(a<=1) return false;
    for(int i=2; i*i<=a; i++)
        if(a%i==0) return false;
    return true;
}
int main(){
    int n, m, msize;
    cin>>msize>>n>>m;
    while(!isprime(msize)) msize++;
    vector<int> t(msize, 0);
    for(int i=0; i<n; i++){
        int a, flag=0;
        cin>>a;
        for(int j=0; j<msize; j++){
            int pos=(j*j+a)%msize;
            if(t[pos]==0){
                flag=1; 
                t[pos]=a;
                break;
            }
        }
        if(flag==0) printf("%d cannot be inserted.\n", a);
    }
    double aver=0.0;
    for(int i=0; i<m; i++){
        int a; 
        cin>>a;
        int cnt=1;
        for(int j=0; j<msize; j++){
            int pos=(j*j+a)%msize;
            if(t[pos]==a||t[pos]==0)
                break;
            cnt++;
        }
        aver+=cnt;
    }
    printf("%.1f\n", aver/m);
    return 0;
} 

PAT 1145 Hashing - Average Search Time

标签:flag   fir   which   name   eth   rom   insert   res   lin   

原文地址:https://www.cnblogs.com/A-Little-Nut/p/9652300.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!