码迷,mamicode.com
首页 > 其他好文 > 详细

Sightseeing trip (POJ - 1734)

时间:2018-09-16 18:40:01      阅读:171      评论:0      收藏:0      [点我收藏+]

标签:where   ecif   scanf   integer   sep   diff   different   while   sid   

There is a travel agency in Adelton town on Zanzibar island. It has decided to offer its clients, besides many other attractions, sightseeing the town. To earn as much as possible from this attraction, the agency has accepted a shrewd decision: it is necessary to find the shortest route which begins and ends at the same place. Your task is to write a program which finds such a route. 

In the town there are N crossing points numbered from 1 to N and M two-way roads numbered from 1 to M. Two crossing points can be connected by multiple roads, but no road connects a crossing point with itself. Each sightseeing route is a sequence of road numbers y_1, ..., y_k, k>2. The road y_i (1<=i<=k-1) connects crossing points x_i and x_{i+1}, the road y_k connects crossing points x_k and x_1. All the numbers x_1,...,x_k should be different.The length of the sightseeing route is the sum of the lengths of all roads on the sightseeing route, i.e. L(y_1)+L(y_2)+...+L(y_k) where L(y_i) is the length of the road y_i (1<=i<=k). Your program has to find such a sightseeing route, the length of which is minimal, or to specify that it is not possible,because there is no sightseeing route in the town.

Input

The first line of input contains two positive integers: the number of crossing points N<=100 and the number of roads M<=10000. Each of the next M lines describes one road. It contains 3 positive integers: the number of its first crossing point, the number of the second one, and the length of the road (a positive integer less than 500).

Output

There is only one line in output. It contains either a string ‘No solution.‘ in case there isn‘t any sightseeing route, or it contains the numbers of all crossing points on the shortest sightseeing route in the order how to pass them (i.e. the numbers x_1 to x_k from our definition of a sightseeing route), separated by single spaces. If there are multiple sightseeing routes of the minimal length, you can output any one of them.

Sample Input

5 7
1 4 1
1 3 300
3 1 10
1 2 16
2 3 100
2 5 15
5 3 20

Sample Output

1 3 5 2

很好的一道 floyd 求最小环问题,因为够冉(无数次WA)

思路:

题还是挺裸的,求最小环我们要先更新“环”,再更新“最短路”。
因为我们的思路是 从 i 直达 k ,再从 k 直达 j ,从 j 再回到 i
因为要直达,所以在要在 k 更新最短路之前更新环


奉上代码
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int oo=0x3f3f3f3f;
int n,m,cnt,ans=oo;
int pre[101][101],path[101],mp[101][101],f[101][101];

void floyd()
{
    for(int k=1;k<=n;++k) 
    {
        for(int i=1;i<k;++i) 
            for(int j=i+1;j<k;++j) 
            {
                if(mp[i][k] && mp[k][j] && f[i][j] && mp[i][k]+mp[k][j]+f[i][j]<ans)
                {
                    ans=mp[i][k]+mp[k][j]+f[i][j];
                    int t=j;
                    cnt=0;
                    while(t!=i)
                    {
                        path[++cnt]=t;
                        t=pre[i][t];
                    }
                    path[++cnt]=i;
                    path[++cnt]=k;
                }
            }
        
        for(int i=1;i<=n;++i) 
            for(int j=1;j<=n;++j) 
            {
                if(f[i][k] && f[k][j] && ((!f[i][j]) || f[i][k]+f[k][j]<f[i][j]))
                {
                    f[i][j]=f[i][k]+f[k][j];
                    pre[i][j]=pre[k][j];
                }
            }
    }
}

int main()
{
    scanf("%d%d",&n,&m);
    for(int i=1;i<=m;++i) {
        int from,to,val;
        scanf("%d%d%d",&from,&to,&val);
        if(!mp[from][to]) {
            mp[from][to]=mp[to][from]=f[from][to]=f[to][from]=val;
            pre[from][to]=from;
            pre[to][from]=to;
        }
        else mp[from][to]=mp[to][from]=f[from][to]=f[to][from]=min(val,mp[from][to]);
    }
    floyd();
    if(ans==oo) {
        printf("No solution.");
        return 0;
    }
    for(int i=1;i<=cnt;++i) printf("%d ",path[i]);
    return 0;
}

 

Sightseeing trip (POJ - 1734)

标签:where   ecif   scanf   integer   sep   diff   different   while   sid   

原文地址:https://www.cnblogs.com/qseer/p/9656820.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!