码迷,mamicode.com
首页 > 其他好文 > 详细

POJ - 1789(Truck History)最小生成树

时间:2018-09-18 22:40:41      阅读:135      评论:0      收藏:0      [点我收藏+]

标签:scanf   mina   tab   title   table   min   scribe   spec   ems   

Truck History

题目链接:

http://poj.org/problem?id=1789

题目:

Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 33974   Accepted: 13146

Description

Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company‘s history, just a single truck type was used but later other types were derived from it, then from the new types another types were derived, and so on. 

Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as 

1/Σ(to,td)d(to,td)


where the sum goes over all pairs of types in the derivation plan such that to is the original type and td the type derived from it and d(to,td) is the distance of the types. 
Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan. 

Input

The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.

Output

For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.

Sample Input

4
aaaaaaa
baaaaaa
abaaaaa
aabaaaa
0

Sample Output

The highest possible quality is 1/3.

题目大意:

给出n个长度为7的字符串,每个字符串代表一个车,定义车的距离是两个字符串间不同字母的个数,题目要求连接所有车的最短距离

Prime算法:

#include <stdio.h>
#include <string.h>
#include <iostream>
using namespace std;
 
const int inf = 0x3f3f3f3f;
char str[2005][10];
int road[2005][2005],minroad,dis[2005],vis[2005],n;
 
int dist(int x,int y)
{
    int d=0;
    for(int i=0;i<7;i++)
        if(str[x][i]!=str[y][i])
            d++;
    return d;
}
 
int prime()
{
    memset(vis,0,sizeof(vis));
    for(int i=1;i<=n;i++)
        dis[i]=road[1][i];
    vis[1]=1;
    int sum=0;
    int c=1;
    int i,j;
    while( c < n )
    {
        minroad = inf;
        for(j=0,i=1;i<=n;i++)
        {
            if(vis[i]==0 && minroad>dis[i])
            {
                minroad = dis[i];
                j=i;
            }
        }
        sum += minroad;
        c++;
        vis[j]=1;
        for(i=1;i<=n;i++)
            if(vis[i]==0 && road[j][i]<dis[i])
            dis[i] = road[j][i];
    }
    return sum;
}
 
int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        getchar();
        if(n==0) break;
        for(int i=1;i<=n;i++)
            scanf("%s",str[i]);
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
                if(i==j) road[i][j]=0;
                else road[i][j]=inf;
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
                road[i][j] = dist(i,j);
        printf("The highest possible quality is 1/%d.\n",prime());
    }
    return 0;
}

krustal算法:

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
using namespace std;
 
const int maxn = 2010;
char str[maxn][10];
int n,allroad,vis[maxn];
 
struct r
{
    int a,b,dis;
}road[maxn*maxn];
 
int dist(int x,int y)
{
    int d=0;
    for(int i=0;i<7;i++)
        if(str[x][i]!=str[y][i])
            d++;
    return d;
}
 
bool cmp(r a,r b)
{
    return a.dis<b.dis;
}
 
int findd(int x)
{
    int a=x;
    while(vis[x]!=x) x=vis[x];
    while(x!=vis[x])
    {
        int z=a;
        a=vis[a];
        vis[z]=x;
    }
    return x;
}
 
int krustal()
{
    sort(road,road+allroad,cmp);
    for(int i=1;i<=n;i++) vis[i]=i;
    int c=0,sum=0;
    for(int i=0;i<allroad;i++)
    {
        int ha=findd(road[i].a);
        int hb=findd(road[i].b);
        if(ha!=hb)
        {
            c++;
            vis[ha]=hb;
            sum += road[i].dis;
            if(c == n-1)break;
        }
    }
    return sum;
}
 
int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        getchar();
        if(n==0) break;
        for(int i=1;i<=n;i++)
            scanf("%s",str[i]);
        allroad = 0;
        for(int i=1;i<=n;i++)
            for(int j=i+1;j<=n;j++)
                {
                    road[allroad].a=i;
                    road[allroad].b=j;
                    road[allroad].dis = dist(i,j);
                    allroad++;
                }
        printf("The highest possible quality is 1/%d.\n",krustal());
    }
    return 0;
}

 

POJ - 1789(Truck History)最小生成树

标签:scanf   mina   tab   title   table   min   scribe   spec   ems   

原文地址:https://www.cnblogs.com/20172674xi/p/9671370.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!