码迷,mamicode.com
首页 > 其他好文 > 详细

HDU - 4405 Aeroplane chess(概率dp)

时间:2018-09-19 23:31:07      阅读:207      评论:0      收藏:0      [点我收藏+]

标签:Plan   other   row   sample   expect   eof   include   color   out   

Aeroplane chess

 
Hzz loves aeroplane chess very much. The chess map contains N+1 grids labeled from 0 to N. Hzz starts at grid 0. For each step he throws a dice(a dice have six faces with equal probability to face up and the numbers on the faces are 1,2,3,4,5,6). When Hzz is at grid i and the dice number is x, he will moves to grid i+x. Hzz finishes the game when i+x is equal to or greater than N. 

There are also M flight lines on the chess map. The i-th flight line can help Hzz fly from grid Xi to Yi (0<Xi<Yi<=N) without throwing the dice. If there is another flight line from Yi, Hzz can take the flight line continuously. It is granted that there is no two or more flight lines start from the same grid. 

Please help Hzz calculate the expected dice throwing times to finish the game. 

InputThere are multiple test cases. 
Each test case contains several lines. 
The first line contains two integers N(1≤N≤100000) and M(0≤M≤1000). 
Then M lines follow, each line contains two integers Xi,Yi(1≤Xi<Yi≤N).   
The input end with N=0, M=0. 
OutputFor each test case in the input, you should output a line indicating the expected dice throwing times. Output should be rounded to 4 digits after decimal point. 
Sample Input

2 0
8 3
2 4
4 5
7 8
0 0

Sample Output

1.1667
2.3441




飞行棋求步数期望。
逆推求期望典型。dp[i]下标状态为所在位置,值为步数。
n=3,m=0
 
e[3]=0
e[2]=1/6e[3]+1
e[1]=1/6e[2]+1/6e[3]+1
e[0]=1/6e[1]+1/6e[2]+1/6e[3]+1
 

#include<bits/stdc++.h>
#define MAX 100010
using namespace std;
typedef long long ll;

int f[MAX];
double dp[MAX];

int main()
{
    int t,n,m,i,j;
    int x,y;
    while(scanf("%d%d",&n,&m)&&n+m){
        memset(f,-1,sizeof(f));
        memset(dp,0,sizeof(dp));
        for(i=1;i<=m;i++){
            scanf("%d%d",&x,&y);
            f[x]=y;
        }
        dp[n]=0;
        for(i=n-1;i>=0;i--){
            if(f[i]>-1){
                dp[i]+=dp[f[i]];
            }
            else{
                for(j=1;j<=6;j++){
                    if(i+j>n) break;
                    dp[i]+=1.0/6*dp[i+j];
                }
                dp[i]++;
            }
        }
        printf("%.4f\n",dp[0]);
    }
    return 0;
}

 

HDU - 4405 Aeroplane chess(概率dp)

标签:Plan   other   row   sample   expect   eof   include   color   out   

原文地址:https://www.cnblogs.com/yzm10/p/9678088.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!