码迷,mamicode.com
首页 > 移动开发 > 详细

HDU 5119 Happy Matt Friends

时间:2018-09-27 00:07:05      阅读:153      评论:0      收藏:0      [点我收藏+]

标签:source   mes   ber   tle   http   ems   ssi   strong   -o   

Happy Matt Friends

Time Limit: 6000/6000 MS (Java/Others)    Memory Limit: 510000/510000 K (Java/Others)
Total Submission(s): 5248    Accepted Submission(s): 2014


Problem Description
Matt has N friends. They are playing a game together.

Each of Matt’s friends has a magic number. In the game, Matt selects some (could be zero) of his friends. If the xor (exclusive-or) sum of the selected friends’magic numbers is no less than M , Matt wins.

Matt wants to know the number of ways to win.
 

 

Input
The first line contains only one integer T , which indicates the number of test cases.

For each test case, the first line contains two integers N, M (1 ≤ N ≤ 40, 0 ≤ M ≤ 106).

In the second line, there are N integers ki (0 ≤ ki ≤ 106), indicating the i-th friend’s magic number.
 

 

Output
For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1) and y indicates the number of ways where Matt can win.
 

 

Sample Input
2 3 2 1 2 3 3 3 1 2 3
 

 

Sample Output
Case #1: 4 Case #2: 2
Hint
In the ?rst sample, Matt can win by selecting: friend with number 1 and friend with number 2. The xor sum is 3. friend with number 1 and friend with number 3. The xor sum is 2. friend with number 2. The xor sum is 2. friend with number 3. The xor sum is 3. Hence, the answer is 4.
 

 

Source
Recommend
liuyiding
题意:有N个人,每个人有一个权值,挑选一些人并将他们的权值异或,求最后得到的值大于M的取法有多少种;
题解:对于每个值都有取和不取两种状态,用dp[i]表示亦或结果为i的方案数;int x = a[i] ^ j;dp[now][x] = dp[pre][x] + dp[pre][j];
参考代码为:
#include <bits/stdc++.h>

using namespace std;
typedef long long LL;
const int maxn = 45;
const int maxm = (1<<20);
int a[maxn];
LL dp[2][maxm];

int main()
{
    int t;
    scanf("%d", &t);
    for(int k = 1; k <= t; k++)
    {
        int n, m;
        scanf("%d%d", &n, &m);
        for(int i = 1; i <= n; i++)
        {
            scanf("%d", &a[i]);
        }
        memset(dp, 0, sizeof(dp));
        dp[0][0] = 1;
        int pre = 0, now = 1;
        for(int i = 1; i <= n; i++)
        {
            for(int j = 0; j < maxm; j++)
            {
                int x = a[i] ^ j;
                dp[now][x] = dp[pre][x] + dp[pre][j];
            }
            swap(now, pre);
        }
        LL ans = 0;
        for(int i = m; i < maxm; i++)
        {
            ans += dp[pre][i];
        }
        printf("Case #%d: %lld\n", k, ans);
    }
    return 0;
}

  

HDU 5119 Happy Matt Friends

标签:source   mes   ber   tle   http   ems   ssi   strong   -o   

原文地址:https://www.cnblogs.com/songorz/p/9710614.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!