码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 5984

时间:2018-10-07 18:49:34      阅读:148      评论:0      收藏:0      [点我收藏+]

标签:contains   expect   miss   should   limit   amp   cas   pos   pes   

 


Pocky
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2095 Accepted Submission(s): 1133


Problem Description
Let’s talking about something of eating a pocky. Here is a Decorer Pocky, with colorful decorative stripes in the coating, of length L.
While the length of remaining pocky is longer than d, we perform the following procedure. We break the pocky at any point on it in an equal possibility and this will divide the remaining pocky into two parts. Take the left part and eat it. When it is not longer than d, we do not repeat this procedure.
Now we want to know the expected number of times we should repeat the procedure above. Round it to 6 decimal places behind the decimal point.

Input
The first line of input contains an integer N which is the number of test cases. Each of the N lines contains two float-numbers L and d respectively with at most 5 decimal places behind the decimal point where 1 ≤ d, L ≤ 150.

Output
For each test case, output the expected number of times rounded to 6 decimal places behind the decimal point in a line.

Sample Input
6
1.0 1.0
2.0 1.0
4.0 1.0
8.0 1.0
16.0 1.0
7.00 3.00

Sample Output
0.000000
1.693147
2.386294
3.079442
3.772589
1.847298

 

 

 

#include <bits/stdc++.h>
using namespace std;
int main()
{
     int t;
     double l,d;
     scanf("%d",&t);
     while(t--){
         scanf("%lf%lf",&l,&d);
         if(l<=d){
             printf("0.000000\n");
         }
         else{
             printf("%.6f\n",1+log(l/d));
         }
     }
    return 0;
}

 

hdu 5984

标签:contains   expect   miss   should   limit   amp   cas   pos   pes   

原文地址:https://www.cnblogs.com/tingtin/p/9750683.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!