码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 3609 二分图多重匹配

时间:2018-10-19 23:46:05      阅读:202      评论:0      收藏:0      [点我收藏+]

标签:HERE   use   its   out   res   cout   amp   Plan   ota   

Escape

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 13005    Accepted Submission(s): 3258


Problem Description
2012 If this is the end of the world how to do? I do not know how. But now scientists have found that some stars, who can live, but some people do not fit to live some of the planet. Now scientists want your help, is to determine what all of people can live in these planets.
 

 

Input
More set of test data, the beginning of each data is n (1 <= n <= 100000), m (1 <= m <= 10) n indicate there n people on the earth, m representatives m planet, planet and people labels are from 0. Here are n lines, each line represents a suitable living conditions of people, each row has m digits, the ith digits is 1, said that a person is fit to live in the ith-planet, or is 0 for this person is not suitable for living in the ith planet.
The last line has m digits, the ith digit ai indicates the ith planet can contain ai people most..
0 <= ai <= 100000
 

 

Output
Determine whether all people can live up to these stars
If you can output YES, otherwise output NO.
 

 

Sample Input
1 1
1
1
2 2
1 0
1 0
1 1
 
Sample Output
YES
NO
 
AC代码
#include <bits/stdc++.h>
#define pb push_back
#define mp make_pair
#define fi first
#define se second
#define all(a) (a).begin(), (a).end()
#define fillchar(a, x) memset(a, x, sizeof(a))
#define huan printf("\n")
#define debug(a,b) cout<<a<<" "<<b<<" "<<endl
#define ffread(a) fastIO::read(a)
using namespace std;
typedef long long ll;
typedef pair<int,int> pii;
const int MAXN = 1e5+10;//左集合大小
const int MAXM = 15;//右集合大小
int uN,vN;//左右集合的数量
int g[MAXN][MAXM];
int linker[MAXM][MAXN];
bool used[MAXM];
int num[MAXM];//右集合的限制
bool dfs(int u)
{
    for(int v = 0; v < vN; v++)
        if(g[u][v] && !used[v])
        {
            used[v] = true;
            if(linker[v][0] < num[v])
            {
                linker[v][++linker[v][0]] = u;
                return true;
            }
            for(int i = 1; i <= num[v]; i++)
                if(dfs(linker[v][i]))
                {
                    linker[v][i] = u;
                    return true;
                }
        }
    return false;
}
int hungary()
{
    int res = 0,flag=0;
    for(int i = 0; i < vN; i++)
        linker[i][0] = 0;
    for(int u = 0; u < uN; u++)
    {
        memset(used,false,sizeof(used));
        if(dfs(u))
            res++;
        else   //当前人不能匹配 直接就是NO了
        {
            flag=1;
            break;
        }
    }
    return flag;
}
int main()
{
    while(scanf("%d%d",&uN,&vN)!=EOF)
    {
        for(int i=0;i<uN;i++)
            for(int j=0;j<vN;j++)
                scanf("%d",&g[i][j]);
        for(int i=0;i<vN;i++)
            scanf("%d",&num[i]);
        if(hungary())
            puts("NO");
        else
            puts("YES");
    }
}

 

 

HDU 3609 二分图多重匹配

标签:HERE   use   its   out   res   cout   amp   Plan   ota   

原文地址:https://www.cnblogs.com/stranger-/p/9819672.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!