码迷,mamicode.com
首页 > 其他好文 > 详细

PAT 1120 Friend Numbers[简单]

时间:2018-10-24 10:45:55      阅读:144      评论:0      收藏:0      [点我收藏+]

标签:mes   math   简单   sed   解决   end   amp   one   auto   

1120 Friend Numbers (20 分)

Two integers are called "friend numbers" if they share the same sum of their digits, and the sum is their "friend ID". For example, 123 and 51 are friend numbers since 1+2+3 = 5+1 = 6, and 6 is their friend ID. Given some numbers, you are supposed to count the number of different frind ID‘s among them.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N. Then N positive integers are given in the next line, separated by spaces. All the numbers are less than 10?4??.

Output Specification:

For each case, print in the first line the number of different frind ID‘s among the given integers. Then in the second line, output the friend ID‘s in increasing order. The numbers must be separated by exactly one space and there must be no extra space at the end of the line.

Sample Input:

8
123 899 51 998 27 33 36 12

Sample Output:

4
3 6 9 26

 题目大意:两个数如果每位相加结果相等,那么结果就是个友好数,现在给出几个数,求他们的友好数。

//就算一个数没有和别的单位数和一样的,也将这个算作友好数。

//我的AC

#include <iostream>
#include <map>
using namespace std;

int main() {
    int n;
    map<int,int> mp;
    cin>>n;
    int t;
    for(int i=0;i<n;i++){
        cin>>t;
        int x,sum=0;
        while(t!=0){
            x=t%10;
            t/=10;
            sum+=x;
        }
        mp[sum]=1;
        sum=0;
    }
    cout<<mp.size()<<\n;
    for(auto it=mp.begin();it!=mp.end();){
        cout<<it->first;//每次都不知道这里的空格该怎么控制?!!!
        if(++it!=mp.end())
            cout<<" ";
    }
    return 0;
}

 

//还是比较简单的,就是用map;

在解决最后输出格式的问题上,可以使用一个if判断,注意应该是++it去判断,而不是it++,深刻地理解了这个前+和后+的区别。

PAT 1120 Friend Numbers[简单]

标签:mes   math   简单   sed   解决   end   amp   one   auto   

原文地址:https://www.cnblogs.com/BlueBlueSea/p/9841548.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!