码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 4122 Alice's mooncake shop

时间:2014-10-11 03:05:15      阅读:332      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   io   os   ar   java   

Alice‘s mooncake shop

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2859    Accepted Submission(s): 723


Problem Description
The Mid-Autumn Festival, also known as the Moon Festival or Zhongqiu Festival is a popular harvest festival celebrated by Chinese people, dating back over 3,000 years to moon worship in China‘s Shang Dynasty. The Zhongqiu Festival is held on the 15th day of the eighth month in the Chinese calendar, which is in September or early October in the Gregorian calendar. It is a date that parallels the autumnal equinox of the solar calendar, when the moon is at its fullest and roundest. 
bubuko.com,布布扣

The traditional food of this festival is the mooncake. Chinese family members and friends will gather to admire the bright mid-autumn harvest moon, and eat mooncakes under the moon together. In Chinese, “round”(圆) also means something like “faultless” or “reuion”, so the roundest moon, and the round mooncakes make the Zhongqiu Festival a day of family reunion.

Alice has opened up a 24-hour mooncake shop. She always gets a lot of orders. Only when the time is K o’clock sharp( K = 0,1,2 …. 23) she can make mooncakes, and We assume that making cakes takes no time. Due to the fluctuation of the price of the ingredients, the cost of a mooncake varies from hour to hour. She can make mooncakes when the order comes,or she can make mooncakes earlier than needed and store them in a fridge. The cost to store a mooncake for an hour is S and the storage life of a mooncake is T hours. She now asks you for help to work out a plan to minimize the cost to fulfill the orders.
 

 

Input
The input contains no more than 10 test cases. 
For each test case:
The first line includes two integers N and M. N is the total number of orders. M is the number of hours the shop opens. 
The next N lines describe all the orders. Each line is in the following format:

month date year H R

It means that on a certain date, a customer orders R mooncakes at H o’clock. “month” is in the format of abbreviation, so it could be "Jan", "Feb", "Mar", "Apr", "May", "Jun", "Jul", "Aug", "Sep", "Oct", "Nov" or "Dec". H and R are all integers. 
All the orders are sorted by the time in increasing order. 
The next line contains T and S meaning that the storage life of a mooncake is T hours and the cost to store a mooncake for an hour is S.
Finally, M lines follow. Among those M lines, the ith line( i starts from 1) contains a integer indicating the cost to make a mooncake during the ith hour . The cost is no more than 10000. Jan 1st 2000 0 o‘clock belongs to the 1st hour, Jan 1st 2000 1 o‘clock belongs to the 2nd hour, …… and so on.

(0<N <= 2500; 0 < M,T <=100000; 0<=S <= 200; R<=10000 ; 0<=H<24)

The input ends with N = 0 and M = 0.
 

 

Output
You should output one line for each test case: the minimum cost. 
 

 

Sample Input
1 10
Jan 1 2000 9 10
5
2
 
20
20
20
10
10
8
7
9
5
10
0
0
 

 

Sample Output
70
 
Hint
“Jan 1 2000 9 10” means in Jan 1st 2000 at 9 o‘clock , there‘s a consumer ordering 10 mooncakes. Maybe you should use 64-bit signed integers. The answer will fit into a 64-bit signed integer.

 

 

这条题的题意是有一家月饼店 , 一共营业 M 个小时 (从2000年1 月1 日 0 时 开始营业), 然后有N个订单 。 

每个订单有所需要的月饼数和需要完成这份订单的时间。

然后店主可以提前制作月饼(可以在任意时刻制造任意多个月饼)。

每个月饼在每个时分的价格不同 ~ 

提前制造的月饼需要用冰箱保存 , 每小时需要费用为 s , 最多可以保存 t 个小时 。

问你完成n份订单所需要的最少费用 ~ 

 

其实就是维护一个 时间差为 t 的制造月饼所需单价单调递增的队列就可以解决了~。 

还有一个点就是把日期转换成小时制  。

注意处理一下闰年

 

 

 

#include <iostream>
#include <cstring>
#include <algorithm>
#include <cstdio>
#include <string>
using namespace std;
const int N = 200100 ;
typedef long long ll;
int  n  , M  , t , s ;

int que[N] , head , tail;


string ss[]= { "Jan", "Feb", "Mar", "Apr", "May", "Jun", "Jul", "Aug", "Sep", "Oct", "Nov" ,"Dec"};

int change( string s )
{
    for( int i = 0 ; i < 12 ; ++i ){
        if( s == ss[i] ) return i + 1 ;
    }
}

int day[13] = {0,31,28,31,30,31,30,31,31,30,31,30,31 };

bool is_leap(int y){  return ( ( y % 100 != 0 && y % 4 == 0  ) || y % 400 == 0 ) ? true : false; }

struct node
{
    int t , c , order;
    bool operator < (const node &a ) const {
        if( t != a.t )return t < a.t ;
        else return order < a.order ;
    }
}e[N];


int cal( int y , int m , int d , int h )
{
    int r_n = 0 ,t = 0 ;
    for( int i = 2000 ; i < y ; ++i )
        if( is_leap(i) ) r_n ++;

    t += ( ( y - 2000 - r_n ) * 365 + r_n * 366 ) * 24  ;

    t += day[m-1] * 24 ;

    if( m > 2 && is_leap(y) ) t += 24 ;

    t += ( d - 1 ) * 24 ;

    t += h ;

    return t;
}

void run()
{
    string ss;
    int y , m , d , h , r ;

    for( int i = 0 ; i < n ; ++i ){
        cin >> ss >> d >> y >> h >> e[i].c ;
        m = change(ss);
        e[i].t = cal(y,m,d,h);
        e[i].order = 1 ;
    }
    cin >> t >> s ;
    for( int i = n ; i < n + M ; ++i ){
        cin >> e[i].c;
        e[i].t = i - n  ;
        e[i].order = 0 ;
    }
    n += M ;
    sort( e , e + n );
    head = tail = 0 ;
    ll ans = 0 ;
    for( int i = 0 ; i < n ; ++i ){
        while( head < tail && e[ que[head] ].t + t < e[i].t ) head++ ;
        if( e[i].order ){
            ans += (ll) ( ( e[i].t - e[ que[head] ].t  ) * s  + e[ que[head] ].c ) * e[i].c ;
            continue;
        }
        while( head < tail && ( e[i].t - e[ que[ tail-1 ] ].t ) * s + e[ que[ tail-1 ] ].c >= e[i].c ) tail -- ;
        que[tail++] = i ;
    }
    cout << ans << endl;
}

int main()
{
    #ifdef LOCAL
        freopen("in","r",stdin);
    #endif
    ios::sync_with_stdio(0);
    for( int i = 1 ; i < 13 ; ++i ) day[i] += day[i-1];
    while( cin >> n >> M && n && M )run();
}

 

HDU 4122 Alice's mooncake shop

标签:des   style   blog   http   color   io   os   ar   java   

原文地址:http://www.cnblogs.com/hlmark/p/4018104.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!