码迷,mamicode.com
首页 > 其他好文 > 详细

区间修改、单点查询

时间:2018-11-04 00:40:40      阅读:248      评论:0      收藏:0      [点我收藏+]

标签:ane   others   print   ali   cep   title   printf   scanf   颜色   

Color the ball

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 29305    Accepted Submission(s): 14264


Problem Description
N个气球排成一排,从左到右依次编号为1,2,3....N.每次给定2个整数a b(a <= b),lele便为骑上他的“小飞鸽"牌电动车从气球a开始到气球b依次给每个气球涂一次颜色。但是N次以后lele已经忘记了第I个气球已经涂过几次颜色了,你能帮他算出每个气球被涂过几次颜色吗?
 

 

Input
每个测试实例第一行为一个整数N,(N <= 100000).接下来的N行,每行包括2个整数a b(1 <= a <= b <= N)。
当N = 0,输入结束。
 

 

Output
每个测试实例输出一行,包括N个整数,第I个数代表第I个气球总共被涂色的次数。
 

 

Sample Input
3 1 1 2 2 3 3 3 1 1 1 2 1 3 0
 

 

Sample Output
1 1 1 3 2 1
 

 

Author
8600
 

 

Source
 
 
//hdu  1556
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <set>
#include <map>
using namespace std;
#define ll long long
#define  lowbit(x) x&(-x)
const int N=1e5+9;
ll  a[N],c[N];
ll  n,x,y;
void  update(ll x,ll  num){
    while(x<=n){
        c[x]+=num;
        x+=lowbit(x);
    }
}
ll  getsum(ll x){
    ll sum = 0;
    while(x>0){
        sum+=c[x];
        x-=lowbit(x);
    }
    return sum;
}
int  main()
{
    while(~scanf("%lld",&n),n){
        for(ll  i = 1 ;i <=n+9;i++){
            a[i]=0;
            c[i] =0;
        }
        for(ll i =0;i<n;i++){
            scanf("%lld%lld",&x,&y);
            update(x,1);
            update(y+1,-1);
        }
        for(ll  i =1;i<=n;i++){
            printf("%lld%c",getsum(i),i==n?\n: );
        }
    }
    return  0;
}

 

区间修改、单点查询

标签:ane   others   print   ali   cep   title   printf   scanf   颜色   

原文地址:https://www.cnblogs.com/tingtin/p/9902412.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!