码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1032 The 3n + 1 problem

时间:2018-11-05 23:43:28      阅读:168      评论:0      收藏:0      [点我收藏+]

标签:cep   int   and   careful   一个   number   this   for   根据   

The 3n + 1 problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 48038    Accepted Submission(s): 17355

Problem Description

Problems in Computer Science are often classified as belonging to a certain class of problems (e.g., NP, Unsolvable, Recursive). In this problem you will be analyzing a property of an algorithm whose classification is not known for all possible inputs.

Consider the following algorithm: 

    1.      input n

    2.      print n

    3.      if n = 1 then STOP

    4.           if n is odd then n <- 3n + 1

    5.           else n <- n / 2

    6.      GOTO 2

Given the input 22, the following sequence of numbers will be printed 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1 

It is conjectured that the algorithm above will terminate (when a 1 is printed) for any integral input value. Despite the simplicity of the algorithm, it is unknown whether this conjecture is true. It has been verified, however, for all integers n such that 0 < n < 1,000,000 (and, in fact, for many more numbers than this.) 

Given an input n, it is possible to determine the number of numbers printed (including the 1). For a given n this is called the cycle-length of n. In the example above, the cycle length of 22 is 16. 

For any two numbers i and j you are to determine the maximum cycle length over all numbers between i and j. 

Input

The input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers will be less than 1,000,000 and greater than 0. 

You should process all pairs of integers and for each pair determine the maximum cycle length over all integers between and including i and j. 

You can assume that no opperation overflows a 32-bit integer.

Output

For each pair of input integers i and j you should output i, j, and the maximum cycle length for integers between and including i and j. These three numbers should be separated by at least one space with all three numbers on one line and with one line of output for each line of input. The integers i and j must appear in the output in the same order in which they appeared in the input and should be followed by the maximum cycle length (on the same line). 

Sample Input

1 10
100 200
201 210
900 1000

Sample Output

1 10 20
100 200 125
201 210 89
900 1000 174

Source

UVA

Recommend

mcqsmall   |   We have carefully selected several similar problems for you:  1021 1002 1020 1017 1012

题解

题目大意就是给定一个范围(注意给的 i , j 没指定谁大谁小),让你求出这个范围内的数字需要进行 3n + 1 的最多的次数。根据题意模拟就好,代码如下:

#include <iostream>
#include <vector>
#include <cstring>
#include <malloc.h>
#include <cstdio>
#define ll long long

using namespace std ;

int main(){
    int a , b ;
    while ( scanf("%d %d" , &a , &b) != EOF ){
        int ans = 0 ;
        for ( int i = min(a , b) ; i <= max(a , b) ; i ++ ){
            int x = i ;
            int time = 0 ;
            while ( x != 1 ){
                time ++ ;
                if ( x & 1 ){
                    x = 3 * x + 1 ;
                }else{
                    x /= 2 ;
                }
            }
            ans = max(ans , ++ time) ;
        }
        printf("%d %d %d\n" , a , b , ans) ;
    }
    return 0 ;
}

HDU 1032 The 3n + 1 problem

标签:cep   int   and   careful   一个   number   this   for   根据   

原文地址:https://www.cnblogs.com/Cantredo/p/9912132.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!