码迷,mamicode.com
首页 > 其他好文 > 详细

HDU1083 :Courses(二分图匹配)

时间:2018-11-06 18:14:58      阅读:197      评论:0      收藏:0      [点我收藏+]

标签:task   correct   input   for   const   mission   des   and   others   

Cources

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11298    Accepted Submission(s): 5299

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1083

Description:

Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions:

. every student in the committee represents a different course (a student can represent a course if he/she visits that course)

. each course has a representative in the committee

Your program should read sets of data from a text file. The first line of the input file contains the number of the data sets. Each data set is presented in the following format:

P N
Count1 Student1 1 Student1 2 ... Student1 Count1
Count2 Student2 1 Student2 2 ... Student2 Count2
......
CountP StudentP 1 StudentP 2 ... StudentP CountP

The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses . from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you‘ll find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N.

There are no blank lines between consecutive sets of data. Input data are correct.

The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line.

An example of program input and output:

Sample Input:

2
3 3
3 1 2 3
2 1 2
1 1
3 3
2 1 3
2 1 3
1 1
Sample Output:
YES
NO
题意:
学生和课程一一匹配,问能不能做到最大匹配。
题解:
二分图匹配模板
代码如下:
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;

const int N = 305;
int n,m,t,ans;
int check[N],match[N],link[N][N];

inline int dfs(int x){
    for(int i=1;i<=m;i++){
        if(!check[i] && link[x][i]){
            check[i]=1;
            if(match[i]==-1 || dfs(match[i])){
                match[i]=x;
                return 1;
            }
        }
    }
    return 0;
}

int main(){
    scanf("%d",&t);
    while(t--){
        scanf("%d%d",&n,&m);
        ans =0 ;
        memset(link,0,sizeof(link));memset(match,-1,sizeof(match));
        for(int i=1,x;i<=n;i++){
            scanf("%d",&x);
            for(int j=1,k;j<=x;j++){
                scanf("%d",&k);
                link[i][k]=1;
            }
        }
        for(int i=1;i<=n;i++){
            memset(check,0,sizeof(check));
            if(dfs(i)) ans++;
        }
        if(ans==n) puts("YES");
        else puts("NO");
    }
    return 0;
}

 

HDU1083 :Courses(二分图匹配)

标签:task   correct   input   for   const   mission   des   and   others   

原文地址:https://www.cnblogs.com/heyuhhh/p/9916863.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!