码迷,mamicode.com
首页 > 其他好文 > 详细

POJ2594:Treasure Exploration(Floyd + 最小路径覆盖)

时间:2018-11-09 00:00:21      阅读:205      评论:0      收藏:0      [点我收藏+]

标签:center   fine   environ   cstring   fir   skill   ted   iostream   one   

Treasure Exploration

Time Limit: 6000MS   Memory Limit: 65536K
Total Submissions: 9794   Accepted: 3975

题目链接http://poj.org/problem?id=2594

Description:

Have you ever read any book about treasure exploration? Have you ever see any film about treasure exploration? Have you ever explored treasure? If you never have such experiences, you would never know what fun treasure exploring brings to you.
Recently, a company named EUC (Exploring the Unknown Company) plan to explore an unknown place on Mars, which is considered full of treasure. For fast development of technology and bad environment for human beings, EUC sends some robots to explore the treasure.
To make it easy, we use a graph, which is formed by N points (these N points are numbered from 1 to N), to represent the places to be explored. And some points are connected by one-way road, which means that, through the road, a robot can only move from one end to the other end, but cannot move back. For some unknown reasons, there is no circle in this graph. The robots can be sent to any point from Earth by rockets. After landing, the robot can visit some points through the roads, and it can choose some points, which are on its roads, to explore. You should notice that the roads of two different robots may contain some same point.
For financial reason, EUC wants to use minimal number of robots to explore all the points on Mars.
As an ICPCer, who has excellent programming skill, can your help EUC?

Input:

The input will consist of several test cases. For each test case, two integers N (1 <= N <= 500) and M (0 <= M <= 5000) are given in the first line, indicating the number of points and the number of one-way roads in the graph respectively. Each of the following M lines contains two different integers A and B, indicating there is a one-way from A to B (0 < A, B <= N). The input is terminated by a single line with two zeros.

Output:

For each test of the input, print a line containing the least robots needed.

Sample Input:

1 0
2 1
1 2
2 0
0 0

Sample Output:

1
1
2

题意

问有向图里,需要最少多少个机器人,能走遍所有的点,并且可以走其它机器人已经走过的路径。

 

题解:

这道题我一开始以为就是最小路径覆盖,结果一直WA...

但其实这题和最小路径覆盖有区别,最小路径覆盖的要求就是在图中找尽量少的路径,让每个节点恰好在一条路径上,单独的一个结点也可以作为一条路径。但是,正是因为每个结点在一条路径上,所以没有重复的路径。

但是这题路径是可以重复的,所以可以利用floyd传递闭包,让原来被“阻断”的路径可以链接起来。

推荐一下这篇博客,挺好的,讲的挺详细的:https://www.cnblogs.com/justPassBy/p/5369930.html

 

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#define mem(x) memset(x,0,sizeof(x))
using namespace std;

const int N = 505 ;
int map[N][N],check[N<<1],match[N<<1],link[N][N<<1];
int n,m,ans;

inline int dfs(int x){
    for(int i=n+1;i<=2*n;i++){
        if(link[x][i] && !check[i]){
            check[i]=1;
            if(!match[i] || dfs(match[i])){
                match[i]=x;
                return 1;
            }
        }
    }
    return 0;
}

int main(){
    while(scanf("%d%d",&n,&m)){
        if(!n && !m) break ;
        mem(map);mem(match);mem(link);ans=0;
        for(int i=1,x,y;i<=m;i++){
            scanf("%d%d",&x,&y);
            map[x][y]=1;
        }
        for(int k=1;k<=n;k++){
            for(int i=1;i<=n;i++){
                if(map[i][k])
                for(int j=1;j<=n;j++){
                    if(map[k][j]) map[i][j]=1;
                }
            }
        }
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
                if(map[i][j]) link[i][j+n]=1;
        for(int i=1;i<=n;i++){
            mem(check);
            if(dfs(i)) ans++;
        }
        printf("%d\n",n-ans);
    }    
    return 0;
} 

 

POJ2594:Treasure Exploration(Floyd + 最小路径覆盖)

标签:center   fine   environ   cstring   fir   skill   ted   iostream   one   

原文地址:https://www.cnblogs.com/heyuhhh/p/9932725.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!