码迷,mamicode.com
首页 > 其他好文 > 详细

PAT 1084 Broken Keyboard[比较]

时间:2018-11-11 20:16:46      阅读:219      评论:0      收藏:0      [点我收藏+]

标签:ring   board   number   分享图片   color   output   git   查找   inf   

1084 Broken Keyboard (20 分)

On a broken keyboard, some of the keys are worn out. So when you type some sentences, the characters corresponding to those keys will not appear on screen.

Now given a string that you are supposed to type, and the string that you actually type out, please list those keys which are for sure worn out.

Input Specification:

Each input file contains one test case. For each case, the 1st line contains the original string, and the 2nd line contains the typed-out string. Each string contains no more than 80 characters which are either English letters [A-Z] (case insensitive), digital numbers [0-9], or _ (representing the space). It is guaranteed that both strings are non-empty.

Output Specification:

For each test case, print in one line the keys that are worn out, in the order of being detected. The English letters must be capitalized. Each worn out key must be printed once only. It is guaranteed that there is at least one worn out key.

Sample Input:

7_This_is_a_test
_hs_s_a_es

Sample Output:

7TI

 题目大意:有一些键盘字母坏了,打不出来,现在给出原输入和显示的字符串,判断哪些按键坏掉了,并且按发现顺序输出。

//第一次提交的发现最后一个点过不去,去牛客网上提交发现以下问题:

技术分享图片

主要是没有考虑到,如果s2已经比对完了,但是s1中还剩下很多没有比对,那么剩下的那些自动就是键盘坏掉的。再判断一下就可以啦。

#include <iostream>
#include <algorithm>
#include<cstdio>
#include<stdio.h>
#include <queue>
#include<cmath>
#include <vector>
#include<set>
using namespace std;

int main()
{
    string s1,s2;
    set<char> st;
    vector<char> vt;
    cin>>s1>>s2;
    int i=0;
    while(i<s1.size()&&i<s2.size()){
        if(s1[i]!=s2[i]){
            if(isalpha(s1[i])){
                s1[i]=toupper(s1[i]);
            }
            if(st.count(s1[i])==0){
                st.insert(s1[i]);
                vt.push_back(s1[i]);
            }
            //s1.substr(i,1);这样写不正确,s1并不会有实质性的变化。。
            //s1=s1.substr(i,1);这样也不对,你要知道你要留下哪部分。。
            s1=s1.erase(i,1);
        }else i++;
    }
    if(i<s1.size()){
        for(int j=i;j<s1.size();j++){
            if(isalpha(s1[j])){
                s1[j]=toupper(s1[j]);
            }
            if(st.count(s1[j])==0){
                st.insert(s1[j]);
                vt.push_back(s1[j]);
            }
        }
    }
//    for(int j=0;j<st.size();j++){
//        cout<<st[i];
//    }
    for(int j=0;j<st.size();j++){
        cout<<vt[j];
    }
    return 0;
}

 

1.在set中查找是否相同使用count函数。

PAT 1084 Broken Keyboard[比较]

标签:ring   board   number   分享图片   color   output   git   查找   inf   

原文地址:https://www.cnblogs.com/BlueBlueSea/p/9943075.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!