码迷,mamicode.com
首页 > 其他好文 > 详细

ZOJ 1760 Doubles

时间:2018-11-13 02:34:06      阅读:120      评论:0      收藏:0      [点我收藏+]

标签:source   term   osi   determine   and   The   lis   double   some   

Doubles


Time Limit: 2 Seconds      Memory Limit: 65536 KB

As part of an arithmetic competency program, your students will be given randomly generated lists of from 2 to 15 unique positive integers and asked to determine how many items in each list are twice some other item in the same list. You will need a program to help you with the grading. This program should be able to scan the lists and output the correct answer for each one. For example, given the list

1 4 3 2 9 7 18 22

your program should answer 3, as 2 is twice 1, 4 is twice 2, and 18 is twice 9.

Input

The input file will consist of one or more lists of numbers. There will be one list of numbers per line. Each list will contain from 2 to 15 unique positive integers. No integer will be larger than 99. Each line will be terminated with the integer 0, which is not considered part of the list. A line with the single number -1 will mark the end of the file. The example input below shows 3 separate lists. Some lists may not contain any doubles.

Output

The output will consist of one line per input list, containing a count of the items that are double some other item.

Sample Input

1 4 3 2 9 7 18 22 0
2 4 8 10 0
7 5 11 13 1 3 0
-1

Sample Output

3
2
0


Source: Mid-Central USA 2003

题解

#include <iostream>
#include <vector>
using namespace std ;
int main(){
    int t ;
    while ( cin >> t && t != -1 ){
        vector<int> arr ;
        arr.push_back(t) ;
        int x ;
        while ( cin >> x && x ){
            arr.push_back(x) ;
        }
        int ans = 0 ;
        bool check[arr.size()] ;
        for ( int i = 0 ; i < arr.size() ; i ++ ){
            check[i] = false ;
        }
        for ( int i = 0 ; i < arr.size() ; i ++ ){
            for ( int j = 0 ; j < arr.size() ; j ++ ){
                if ( arr[i] * 2 == arr[j] ){
                    ans ++ ;
                    check[i] = true ;
//                    break ;
                }
                if ( arr[j] * 2 == arr[i] && arr[i] == true ){
                    ans ++ ;
                }
            }
        }
        cout << ans << endl ;
    }
    return 0 ;
}

ZOJ 1760 Doubles

标签:source   term   osi   determine   and   The   lis   double   some   

原文地址:https://www.cnblogs.com/Cantredo/p/9949859.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!