码迷,mamicode.com
首页 > 其他好文 > 详细

zoj 3822 Domination(2014牡丹江区域赛D题)

时间:2014-10-12 18:35:28      阅读:297      评论:0      收藏:0      [点我收藏+]

标签:algorithm

Domination

Time Limit: 8 Seconds      Memory Limit: 131072 KB      Special Judge

Edward is the headmaster of Marjar University. He is enthusiastic about chess and often plays chess with his friends. What‘s more, he bought a large decorative chessboard with N rows and M columns.

Every day after work, Edward will place a chess piece on a random empty cell. A few days later, he found the chessboard was dominated by the chess pieces. That means there is at least one chess piece in every row. Also, there is at least one chess piece in every column.

"That‘s interesting!" Edward said. He wants to know the expectation number of days to make an empty chessboard of N × M dominated. Please write a program to help him.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

There are only two integers N and M (1 <= NM <= 50).

Output

For each test case, output the expectation number of days.

Any solution with a relative or absolute error of at most 10-8 will be accepted.

Sample Input

2
1 3
2 2

Sample Output

3.000000000000
2.666666666667

概率dp,i为第i天,j为有j行已经被覆盖,k为k列已经被覆盖,则每个dp[i][j][k]都可以由上dp[i-1]推出。

代码:
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
using namespace std;
double dp[5000][55][55];
int main(){
    int m,n;
    int T;
    scanf("%d",&T);
    memset(dp, 0, sizeof(dp));
    dp[0][0][0]=1;

    while (T--) {
        scanf("%d %d",&m,&n);
        for(int i=1;i<=m*n+1-min(m, n);++i){
            for(int j=1;j<=i&&j<=m;++j){
                for(int k=1;k<=i&&k<=n;++k){
                    if(j>m){
                        dp[i][j][k]=0;
                        continue;
                    }
                    if(k>n) {
                        dp[i][j][k]=0;
                        continue;
                    }
                    if(j!=m||k!=n)
                    dp[i][j][k]=dp[i-1][j-1][k-1]*(double)((m+1-j)*(n+1-k))/(double)(m*n-i+1)+dp[i-1][j-1][k]*(double)(k*(m+1-j))/(double)(m*n-i+1)+dp[i-1][j][k-1]*(double)(j*(n+1-k))/(double)(m*n-i+1)+dp[i-1][j][k]*(double)(j*k+1-i)/(double)(m*n-i+1);
                    else
                    dp[i][j][k]=dp[i-1][j-1][k-1]*(double)((m+1-j)*(n+1-k))/(double)(m*n-i+1)+dp[i-1][j-1][k]*(double)(k*(m+1-j))/(double)(m*n-i+1)+dp[i-1][j][k-1]*(double)(j*(n+1-k))/(double)(m*n-i+1);
                }
            }
        }
        double result=0;
        for(int i=1;i<=m*n+1-min(m, n);++i){
            result+=i*dp[i][m][n];
        }
        printf("%.12f\n",result);
    }
    return 0;
}



zoj 3822 Domination(2014牡丹江区域赛D题)

标签:algorithm

原文地址:http://blog.csdn.net/caduca/article/details/40018983

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!