码迷,mamicode.com
首页 > 其他好文 > 详细

HDoj-2095-与众不同

时间:2014-10-12 19:14:08      阅读:208      评论:0      收藏:0      [点我收藏+]

标签:c语言   c   printf   numbers   each   

Problem Description

In the new year party, everybody will get a "special present".Now it‘s your turn to get your special present, a lot of presents now putting on the desk, and only one of them will be yours.Each present has a card number on it, and your present‘s card number will be the one that different from all the others.For example, there are 5 present, and their card numbers are 1, 2, 3, 2, 1.so your present will be the one with the card number of 3, because 3 is the number that different from all the others.

Input

The input file will consist of several cases.
Each case will be presented by an integer n (1<=n<=200, and n is odd) at first. Following that, n positive integers will be given in a line. These numbers indicate the card numbers of the presents.n = 0 ends the input.

Output

For each case, output an integer in a line, which is the card number of your present.

Sample Input

5
1 1 3 2 2
3
1 2 1
0

Sample Output

3
2
#include<stdio.h>
int main()
{
    int T;
    int n,m;
    while(~scanf("%d",&T),T){
        scanf("%d",&n);
        
        while(--T){
            scanf("%d",&m);
            n=m^n;               
       }
        printf("%d\n",n);
    }
    
    return 0;
}
 


HDoj-2095-与众不同

标签:c语言   c   printf   numbers   each   

原文地址:http://blog.csdn.net/holyang_1013197377/article/details/40019657

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!