码迷,mamicode.com
首页 > 其他好文 > 详细

ZOJ - 3822 Domination (DP)

时间:2014-10-12 21:51:28      阅读:382      评论:0      收藏:0      [点我收藏+]

标签:style   blog   color   io   os   ar   for   sp   div   

Edward is the headmaster of Marjar University. He is enthusiastic about chess and often plays chess with his friends. What‘s more, he bought a large decorative chessboard with N rows and M columns.

Every day after work, Edward will place a chess piece on a random empty cell. A few days later, he found the chessboard was dominated by the chess pieces. That means there is at least one chess piece in every row. Also, there is at least one chess piece in every column.

"That‘s interesting!" Edward said. He wants to know the expectation number of days to make an empty chessboard of N × M dominated. Please write a program to help him.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

There are only two integers N and M (1 <= NM <= 50).

Output

For each test case, output the expectation number of days.

Any solution with a relative or absolute error of at most 10-8 will be accepted.

Sample Input

2
1 3
2 2

Sample Output

3.000000000000
2.666666666667
题意:求放石子使得每行没列都有石子个数的期望
思路:先求概率,然后再用期望公式计算,设dp[i][j][k]表示放i个石子后行有j,列有k至少有一个石子的概率,然后就是4种情况的讨论,1.使得行和列都加1,2.行加1,3.列加1
4.行和列都不加1
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
const int maxn = 55;

double dp[maxn*maxn][maxn][maxn];
int n, m;

int main() {
	int t;
	scanf("%d", &t);
	while (t--) {
		scanf("%d%d", &n, &m);
		memset(dp, 0, sizeof(dp));
		dp[1][1][1] = 1.0;
		for (int i = 1; i < n*m; i++) 
			for (int j = 1; j <= n; j++) 
				for (int k = 1; k <= m; k++)
					if (dp[i][j][k] > 0) {
						dp[i+1][j+1][k+1] += dp[i][j][k] * (n - j) * (m - k) / (n * m - i);
						dp[i+1][j+1][k] += dp[i][j][k] * (n - j) * k / (n * m - i);

						dp[i+1][j][k+1] += dp[i][j][k] * j * (m - k) / (n * m - i);
						if (j < n || k < m)
							dp[i+1][j][k] += dp[i][j][k] * (j * k - i) / (n * m - i);
					}
		double ans = 0;
		for (int i = 1; i <= n * m; i++)
			ans += dp[i][n][m] * i;
		printf("%.8lf\n", ans);
	}
	return 0;
}


ZOJ - 3822 Domination (DP)

标签:style   blog   color   io   os   ar   for   sp   div   

原文地址:http://blog.csdn.net/u011345136/article/details/40022863

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!