码迷,mamicode.com
首页 > 其他好文 > 详细

A Chess Game POJ - 2425

时间:2018-11-28 22:28:38      阅读:185      评论:0      收藏:0      [点我收藏+]

标签:pos   pie   div   let   case   tput   which   nim   nes   

Let‘s design a new chess game. There are N positions to hold M chesses in this game. Multiple chesses can be located in the same position. The positions are constituted as a topological graph, i.e. there are directed edges connecting some positions, and no cycle exists. Two players you and I move chesses alternately. In each turn the player should move only one chess from the current position to one of its out-positions along an edge. The game does not end, until one of the players cannot move chess any more. If you cannot move any chess in your turn, you lose. Otherwise, if the misfortune falls on me... I will disturb the chesses and play it again. 

Do you want to challenge me? Just write your program to show your qualification!

Input

Input contains multiple test cases. Each test case starts with a number N (1 <= N <= 1000) in one line. Then the following N lines describe the out-positions of each position. Each line starts with an integer Xi that is the number of out-positions for the position i. Then Xi integers following specify the out-positions. Positions are indexed from 0 to N-1. Then multiple queries follow. Each query occupies only one line. The line starts with a number M (1 <= M <= 10), and then come M integers, which are the initial positions of chesses. A line with number 0 ends the test case.

Output

There is one line for each query, which contains a string "WIN" or "LOSE". "WIN" means that the player taking the first turn can win the game according to a clever strategy; otherwise "LOSE" should be printed.

Sample Input

4
2 1 2
0
1 3
0
1 0
2 0 2
0

4
1 1
1 2
0
0
2 0 1
2 1 1
3 0 1 3
0

Sample Output

WIN
WIN
WIN
LOSE
WIN

思路:树上nim,叶子节点nim为0,父亲节点递归儿子得到sg值,答案就是每个石子所在点的sg值异或和。

技术分享图片
#include <iostream>
#include <cstdio>
#include <string.h>
using namespace std;
int mp[1001][1001];
int SG[1001];
int N;
 int DFS(int n)
{
    int i;
    if(SG[n]!=-1)
        return SG[n];
    bool next[1001];
    memset(next, 0, sizeof(next));
    for(i = 0; i < N; ++i)
    {
        if(mp[n][i] != -1)
            next[DFS(i)] = 1;
    }
    i = 0;
    while(next[i])
        i++;
    return SG[n] = i;
}
int main()
{
    int i, j, k, t;
    int X;
    int tp, ans;
    while(scanf("%d", &N)!=EOF)
    {
        memset(mp, -1, sizeof(mp));
        memset(SG, -1, sizeof(SG));
        for(i = 0; i < N; ++i)
        {
            scanf("%d", &k);
            if(k==0) SG[i] = 0;
            for(j =0 ; j < k; ++j)
            {
                scanf("%d", &t);
                mp[i][t] = 1;
            }
        }
        while(scanf("%d", &X))
        {
            if(X==0) break;
            ans = 0;
            for(i = 0; i < X; ++i)
            {
                scanf("%d", &tp);
                ans = ans ^ DFS(tp);
            }
            if(ans) printf("WIN\n");
            else printf("LOSE\n");
        }
    }
    return 0;
}
View Code

转载

A Chess Game POJ - 2425

标签:pos   pie   div   let   case   tput   which   nim   nes   

原文地址:https://www.cnblogs.com/astonc/p/10034394.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!