码迷,mamicode.com
首页 > 其他好文 > 详细

FatMouse and Cheese

时间:2018-12-30 15:12:43      阅读:203      评论:0      收藏:0      [点我收藏+]

标签:label   NPU   put   cte   queue   problem   names   输入   直线   

题目描述:

FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he‘s going to enjoy his favorite food. 

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole. 

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.

输入:

There are several test cases. Each test case consists of 

a line containing two integers between 1 and 100: n and k 
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on. 
The input ends with a pair of -1‘s.

输出:

For each test case output in a line the single integer giving the number of blocks of cheese collected.

样例:

Sample Input

3 1
1 2 5
10 11 6
12 12 7
-1 -1

Sample Output

37
题目大意:
给一张n*n的图,每一个点都有一定数量的奶酪,有一只老鼠从(0,0)出发,一次最多只能走k步,只能走直线,且下一个点的奶酪数要大于该点的奶酪数,问老鼠能吃到的最大奶酪总数。

代码:
#include<iostream>
#include<stdio.h>
#include<queue> 
#include<algorithm>
#include<string.h>
using namespace std;
int temp[100][100];
int p[100][100];
int n,k;
int w(int a,int b)
{
    if(temp[a][b]!=0) return temp[a][b];
    int *q,num,cur=0;
    q=new int [4*k];
    for(int i=0;i<k;++i){
        if(b-i-1<0||p[a][b-i-1]<=p[a][b]) q[i]=0;
        else q[i]=w(a,b-i-1);
        if(b+i+1>=n||p[a][b+i+1]<=p[a][b]) q[i+k]=0;
        else q[i+k]=w(a,b+i+1);
        if(a-i-1<0||p[a-i-1][b]<=p[a][b]) q[i+2*k]=0;
        else q[i+2*k]=w(a-i-1,b);
        if(a+i+1>=n||p[a+i+1][b]<=p[a][b]) q[i+3*k]=0;
        else q[i+3*k]=w(a+i+1,b);
    }
    for(int i=0;i<4*k;++i){
        if(q[i]>cur) cur=q[i];
    }
    return temp[a][b]=p[a][b]+cur;
}
int main()
{
    scanf("%d%d",&n,&k);
    while(!(n==-1&&k==-1)){
        for(int i=0;i<n;++i){
            for(int j=0;j<n;++j) scanf("%d",&p[i][j]);
        }
        printf("%d\n",w(0,0));
        memset(temp,0,10000*sizeof(int));
        scanf("%d%d",&n,&k);
    }
    return 0;
 } 

从(0,0)出发进行深搜,并记忆每一个点的最大值,避免重复计算,根据最大步数建立动态数组逐个判断每个方向每一步的最大值。

当时困扰了很久才醒悟到的是:1.同一条路径不会重复走一格;2.每一格的最大值不随选择的路径而变化。

FatMouse and Cheese

标签:label   NPU   put   cte   queue   problem   names   输入   直线   

原文地址:https://www.cnblogs.com/-y-i-/p/10199436.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!