码迷,mamicode.com
首页 > 其他好文 > 详细

Sicily 1732 Alice and Bob (二进制数的最大公约数)

时间:2014-05-15 03:20:59      阅读:383      评论:0      收藏:0      [点我收藏+]

标签:sicily   二进制数的最大公约数   

链接: http://soj.me/1732

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description:

Alice is a beautiful and clever girl. Bob would like to play with Alice.
One day, Alice got a very big rectangle and wanted to divide it into small square pieces. Now comes a problem: if all pieces of small squares are of the same size, how big could the squares be? To Alice, it’s easy to solve the problem. However, she was very busy, so she asked Bob to help her. You know Alice is such a lovely girl and of course Bob won’t refuse her request. But Bob is not so smart and he is especially weak in math. So he turns to you—a genius at programming.
Alice will inform Bob the length and width of the big rectangle, and Bob have to tell her the longest length for the small square. All of these numbers are in their binary representations.

Input:

The first line of the input is a positive integer. This is the number of the test cases followed. Each test case contains two integer L and W in their binary representation which tells you the length and width of the very big rectangle (0<L, W<2^1000). There may be one or several spaces between these integers.

Output:

The output of the program should consist of one line of output for each test case. The output of each test case only contains the longest length for the small squares in its binary representation. No any redundant spaces are needed.

Sample Input:

2
100 1000
100 110
Sample Output:

100
10


分析:本题的大意就是给出两个数的二进制,求出他们的最大公约数,要用辗转相除法,由于本题的数据范围较大,需要使用高精度,如果简单套用使用辗转相除法gcd(n, m) = gcd(m, n%m)来求的话,那么就要完成一个高精度的除法的程序;
因为本题的输入和输出都使用二进制表示,所以可以使用以下方法来求最大公约数,(只需要用高精度的除法和以为运算);
本题采用的算法如下:
if a = 2p, b = 2q, then gcd(a, b) = 2*gcd(p, q);
if a = 2p, b = 2q+1, then gcd(a, b) = gcd(p, b);
if a = 2p+1, b = 2q, then gcd(a, b) = gcd(a, q);
if a = 2p+1, b = 2q+1, then gcd(a, b) = gcd(a-b, b) (assume a > b)
容易看出前三种情况都会导致其中一个整数减半,这样递减的速度是很快的,而且由于输入的是以二进制的方式输入,判断a, b的方式很简单;
那会不会连续调用第四种情况呢?答案是不会的,原因是:
当a = 2p+1, b = 2q+1时:
gcd(a, b) = gcd(a-b, b) = gcd(2(p-q), 2q+1) = gcd(p-q, 2q+1);
明显不可能出现连续调用第四种情况,时间复杂度也和标准的转转相除法一样是O(logn);


代码如下:

// Problem#: 1732
// Submission#: 2822044
// The source code is licensed under Creative Commons Attribution-NonCommercial-ShareAlike 3.0 Unported License
// All Copyright reserved by Informatic Lab of Sun Yat-sen University
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#define MAXN 10005
#define RST(N)memset(N, 0, sizeof(N))
using namespace std;

typedef struct Node_
{
    int len;
    int v[MAXN];
}Node;

Node n, m;
int cas;
char str1[MAXN], str2[MAXN];

Node Tr(char *str)     //把字符串转换成数字形式;
{
    Node N;
    int len = strlen(str);
    N.len = len;
    for(int i=0; i<len; i++) N.v[i] = str[len-1-i]-‘0‘;
    return N;
}

bool CMP(Node n, Node m)  //比较两个数的大小;
{
    if(n.len < m.len) return true;
    if(n.len > m.len) return false;
    for(int i=n.len-1; i>=0; i--) {
        if(n.v[i] < m.v[i]) return true;
        else if(n.v[i] > m.v[i]) return false;
    }
    return false;
}

Node Minus(Node n, Node m)   //大整数高精度相减,注意是二进制相减;
{
    Node N = n;
    int borrow = 0, temp, i;   //borrow为借位;
    for(i=0; i<m.len; i++) {    //从低位减起;
        temp = N.v[i] - borrow - m.v[i];
        if(temp >= 0) {      //没有借位;
            borrow = 0, N.v[i] = temp;
        }else {
            borrow = 1, N.v[i] = temp + 2;
        }
    }
    for(; i<n.len; i++) {   //处理剩余位数;(假设n > m)
        temp = N.v[i] - borrow;
        if(temp >= 0) {
            borrow = 0, N.v[i] = temp;
        }else {
            borrow = 1, N.v[i] = temp + 2;
        }
    }
    while(N.len >= 1 && !N.v[N.len-1]) N.len--;
    return N;
}

Node div(Node n)  //大整数除2;由于是二进制,其本质就是移位;
{
    Node ret;
    ret.len = n.len-1;
    for(int i=0; i<ret.len; i++) ret.v[i] = n.v[i+1];
    return ret;
}

void gcd(Node n, Node m)   //求大整数的公约数;
{
    long cnt = 0;
    while(n.len && m.len) {
        if(n.v[0]) {
            if(m.v[0]) {   //a = 2p+1, b = 2q+1 情况
                if(CMP(n, m)) m = Minus(m, n);
                else n = Minus(n, m);
            }else m = div(m);   //a = 2p+1, b = 2q情况;
        }else {
            if(m.v[0]) n = div(n);   //a = 2p, b = 2q+1情况;
            else {
                n = div(n), m = div(m);   //a = 2p, b = 2q情况;
                cnt++;
            }
        }
    }
    if(m.len) for(int i=m.len-1; i>=0; i--) printf("%d", m.v[i]);   //输出结果;
    else for(int i=n.len-1; i>=0; i--) printf("%d", n.v[i]);
    while(cnt--) printf("0");
    printf("\n");
}

int main()
{
    scanf("%d", &cas);
    while(cas--) {
        scanf("%s %s", str1, str2);
        n = Tr(str1), m = Tr(str2);
        gcd(n, m);
    }
    return 0;
}                                



Sicily 1732 Alice and Bob (二进制数的最大公约数),布布扣,bubuko.com

Sicily 1732 Alice and Bob (二进制数的最大公约数)

标签:sicily   二进制数的最大公约数   

原文地址:http://blog.csdn.net/keshacookie/article/details/25735905

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!