码迷,mamicode.com
首页 > 其他好文 > 详细

Hie with the Pie POJ - 3311

时间:2019-01-19 11:10:26      阅读:142      评论:0      收藏:0      [点我收藏+]

标签:tac   ini   live   mini   iss   signed   driver   ogr   while   

 Hie with the Pie POJ - 3311 

The Pizazz Pizzeria prides itself in delivering pizzas to its customers as fast as possible. Unfortunately, due to cutbacks, they can afford to hire only one driver to do the deliveries. He will wait for 1 or more (up to 10) orders to be processed before he starts any deliveries. Needless to say, he would like to take the shortest route in delivering these goodies and returning to the pizzeria, even if it means passing the same location(s) or the pizzeria more than once on the way. He has commissioned you to write a program to help him.

Input

Input will consist of multiple test cases. The first line will contain a single integer n indicating the number of orders to deliver, where 1 ≤ n ≤ 10. After this will be n + 1 lines each containing n + 1 integers indicating the times to travel between the pizzeria (numbered 0) and the n locations (numbers 1 to n). The jth value on the ith line indicates the time to go directly from location i to location j without visiting any other locations along the way. Note that there may be quicker ways to go from i to j via other locations, due to different speed limits, traffic lights, etc. Also, the time values may not be symmetric, i.e., the time to go directly from location i to j may not be the same as the time to go directly from location j to i. An input value of n = 0 will terminate input.

Output

For each test case, you should output a single number indicating the minimum time to deliver all of the pizzas and return to the pizzeria.

Sample Input

3
0 1 10 10
1 0 1 2
10 1 0 10
10 2 10 0
0

Sample Output

8


题意:一个快递员送n个物品,给出i地点到j地点的长度,送完所有的后返回起始点0,问最短可以跑多少
思路:n最大为10,先跑一遍floyd,之后直接全排列所有的情况,一开始没有初始化minnWA了。。。
技术分享图片
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<sstream>
#include<cmath>
#include<stack>
#include<cstdlib>
#include <vector>
#include<queue>
using namespace std;

#define ll long long
#define llu unsigned long long
#define INF 0x3f3f3f3f
#define PI acos(-1.0)
const int maxn =  1e5+5;
const ll mod = 1e9+7;

int n;
ll cost[15][15];
int arr[15];
void swap(int x,int y)
{
    int temp=arr[x];
    arr[x]=arr[y];
    arr[y]=temp;
}
ll minn=INF;
int resove(int x)//递归函数
{
    if(x==n)//当尝试对不存在的数组元素进行递归时,标明所有数已经排列完成,输出。
    {
        ll ans=0;
        for(int i=0;i<n-1;i++)
        {
            //printf("%d->%d ",arr[i]+1,arr[i+1]+1);
            ans += cost[arr[i]+1][arr[i+1]+1];
        }
        //cout<<arr[0]+1 << " "<<arr[n-1]+1;
        //cout<<endl;
        ans = ans + cost[0][arr[0]+1] + cost[arr[n-1]+1][0];

        minn = min(minn,ans);
       // cout<<minn<<endl;
        return 0;
    }
    for(int i=x;i<n;i++)
    {
        swap(x,i);
        resove(x+1);
        swap(x,i);
    }

}
//int main()
//{
//    for(int i=0;i<=12;i++)
//        arr[i] = i;
//    n=4;
//    resove(0);
//}

void floyd()
{
    for(int k=0;k<=n;k++)
        for(int i=0;i<=n;i++)
            for(int j=0;j<=n;j++)
              cost[i][j] = min(cost[i][j],cost[i][k] + cost[k][j]);
}
int main()
{

    while(scanf("%d",&n) && n)
    {

        minn = INF;
//        for(int i=0;i<=15;i++)
//            for(int j=0;j<=15;j++)
//                cost[i][j]=INF;
        for(int i=0;i<=n;i++)
        {
            for(int j=0;j<=n;j++)
            {
                scanf("%lld",&cost[i][j]);
            }
        }
        floyd();
        for(int i=0;i<=14;i++)
            arr[i] = i;

        resove(0);
        cout<<minn<<endl;
    }
}
/*
Sample Input
3
0 1 10 10
1 0 1 2
10 1 0 10
10 2 10 0
0
Sample Output
8
 */
View Code

 



Hie with the Pie POJ - 3311

标签:tac   ini   live   mini   iss   signed   driver   ogr   while   

原文地址:https://www.cnblogs.com/smallhester/p/10290462.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!