码迷,mamicode.com
首页 > 其他好文 > 详细

POJ2431--Expedition(优先队列)

时间:2019-01-26 11:06:16      阅读:146      评论:0      收藏:0      [点我收藏+]

标签:min   travel   repair   sar   addition   NPU   unit   between   hat   

Description

A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck‘s fuel tank. The truck now leaks one unit of fuel every unit of distance it travels. 

To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows can stop to acquire additional fuel (1..100 units at each stop). 

The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000). 

Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all. 

Input

* Line 1: A single integer, N 

* Lines 2..N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop. 

* Line N+2: Two space-separated integers, L and P

Output

* Line 1: A single integer giving the minimum number of fuel stops necessary to reach the town. If it is not possible to reach the town, output -1.

Sample Input

4
4 4
5 2
11 5
15 10
25 10

Sample Output

2

Hint

INPUT DETAILS: 

The truck is 25 units away from the town; the truck has 10 units of fuel. Along the road, there are 4 fuel stops at distances 4, 5, 11, and 15 from the town (so these are initially at distances 21, 20, 14, and 10 from the truck). These fuel stops can supply up to 4, 2, 5, and 10 units of fuel, respectively. 

OUTPUT DETAILS: 

Drive 10 units, stop to acquire 10 more units of fuel, drive 4 more units, stop to acquire 5 more units of fuel, then drive to the town.
 
 
 
变换思考方式:
记录每一个经过的加油站,油量用优先队列来维护,只有走到没有油的时候,取出最大的油量,加上
#include<iostream>
#include<queue>
#include<algorithm>
using namespace std;
struct node{
    int dis;
    int fuel;
    bool operator<(const node& n)const{
        return dis>n.dis;
    }
}stop[10005];
int main(){
    int n,l,p;
    cin>>n;
    priority_queue<int> que;
    for(int i=0;i<n;i++){
        cin>>stop[i].dis>>stop[i].fuel;
    }
    cin>>l>>p;
    int ans=0;
    que.push(p);
    sort(stop,stop+n);
    int t=0;
    while(l>0&&!que.empty()){
        int x=que.top();
        que.pop();
        l-=x;
        ans++;
        for(int i=t;i<n;i++){
            if(l<=stop[t].dis){
                que.push(stop[t].fuel);
                t++;
            }
        }
    }
    if(l>0)
        cout<<-1<<endl;
    else 
        cout<<ans-1<<endl;
    return 0;
}

 

POJ2431--Expedition(优先队列)

标签:min   travel   repair   sar   addition   NPU   unit   between   hat   

原文地址:https://www.cnblogs.com/albert67/p/10322524.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!