码迷,mamicode.com
首页 > 其他好文 > 详细

NYOJ467 中缀式变后缀式 【栈】

时间:2014-10-16 23:43:13      阅读:192      评论:0      收藏:0      [点我收藏+]

标签:nyoj467

中缀式变后缀式

时间限制:1000 ms  |  内存限制:65535 KB
难度:3
描述
人们的日常习惯是把算术表达式写成中缀式,但对于机器来说更“习惯于”后缀式,关于算术表达式的中缀式和后缀式的论述一般的数据结构书都有相关内容可供参看,这里不再赘述,现在你的任务是将中缀式变为后缀式。
输入
第一行输入一个整数n,共有n组测试数据(n<10)。
每组测试数据只有一行,是一个长度不超过1000的字符串,表示这个运算式的中缀式,每个运算式都是以“=”结束。这个表达式里只包含+-*/与小括号这几种符号。其中小括号可以嵌套使用。数据保证输入的操作数中不会出现负数。
数据保证除数不会为0
输出
每组都输出该组中缀式相应的后缀式,要求相邻的操作数操作符用空格隔开。
样例输入
2
1.000+2/4=
((1+2)*5+1)/4=
样例输出
1.000 2 4 / + =
1 2 + 5 * 1 + 4 / =
来源
数据结构
上传者
mix_math

题意:...

题解:需要两个栈,一个是符号sta栈,一个是后缀式out栈,每次在buf中读取字符时,如果是数字或者‘.’,则直接存到out栈里,如果是别的字符,则将它放入sta栈,前提是保证sta栈内优先级严格递减。


#include <stdio.h>
#include <string.h>
#include <ctype.h>

#define maxn 1010

char buf[maxn], out[maxn << 1];
char sta[maxn]; // 符号栈
int id, id2;

int getLevel(char ch) {
	switch(ch) {
		case '(': return 0;
		case '+':
		case '-': return 1;
		case '*':
		case '/': return 2;
	}
}

void check(char ch) {
	int level;
	if(ch == '(') sta[id2++] = ch;
	else if(ch == ')') {
		while(sta[id2-1] != '(') {
			out[id++] = sta[--id2];
			out[id++] = ' ';
		}
		--id2;	
	} else {
		while(id2 && getLevel(sta[id2-1]) >= getLevel(ch)) {
			out[id++] = sta[--id2]; out[id++] = ' ';
		}
		sta[id2++] = ch;
	}
}

void solve() {
	int i, sign; id = id2 = 0;
	for(i = sign = 0; buf[i] != '='; ++i) {
		if(isdigit(buf[i]) || buf[i] == '.') {
			out[id++] = buf[i]; sign = 1;
		} else {
			if(sign) {
				out[id++] = ' ';
				sign = 0;
			}
			check(buf[i]);
		}
	}
	while(id2) {
		if(sign) {
			out[id++] = ' ';
			sign = 0;
		}
		out[id++] = sta[--id2];
		out[id++] = ' ';
	}
	out[id] = '\0';
	printf("%s=\n", out);
}

int main() {
	// freopen("stdin.txt", "r", stdin);
	int t;
	scanf("%d", &t);
	while(t--) {
		scanf("%s", buf);
		solve();
	}
	return 0;
}


NYOJ467 中缀式变后缀式 【栈】

标签:nyoj467

原文地址:http://blog.csdn.net/chang_mu/article/details/40157149

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!