码迷,mamicode.com
首页 > 其他好文 > 详细

POJ2253 Frogger 【Dijkstra】

时间:2014-10-16 23:46:53      阅读:239      评论:0      收藏:0      [点我收藏+]

标签:poj2253

Frogger
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 26417   Accepted: 8592

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists‘ sunscreen, he wants to avoid swimming and instead reach her by jumping. 
Unfortunately Fiona‘s stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 
To execute a given sequence of jumps, a frog‘s jump range obviously must be at least as long as the longest jump occuring in the sequence. 
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones. 

You are given the coordinates of Freddy‘s stone, Fiona‘s stone and all other stones in the lake. Your job is to compute the frog distance between Freddy‘s and Fiona‘s stone. 

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy‘s stone, stone #2 is Fiona‘s stone, the other n-2 stones are unoccupied. There‘s a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

Source

题意:从起点到终点有多条线路,找出所有线路中最大边最小的值。

题解:Dijkstra,dis数组存取当前点到原点的“割”;


#include <stdio.h>
#include <math.h>
#include <string.h>

#define maxn 202
#define inf 0x3f3f3f3f

int n;
struct Node {
	int x, y;
} Stone[maxn];
double map[maxn][maxn], dis[maxn];
bool vis[maxn];

double min(double a, double b) {
	return a < b ? a : b;
}

double max(double a, double b) {
	return a > b ? a : b;
}

double calDis(int i, int j) {
	double x = Stone[i].x - Stone[j].x;
	double y = Stone[i].y - Stone[j].y;
	return sqrt(x * x + y * y);
}

int getNext() {
	int pos = -1, i;
	double val = inf;
	for(i = 0; i < n; ++i)
		if(!vis[i] && dis[i] < val) {
			val = dis[i]; pos = i; 
		}
	return pos;
}

void Dijkstra(int start, int end) {
	int u = start, v, i;
	for(i = 0; i < n; ++i) {
		vis[i] = 0; dis[i] = inf;
	}
	dis[u] = 0.0;
	while(u != -1) {
		vis[u] = 1;
		for(i = 0; i < n; ++i)
			dis[i] = min(dis[i], max(map[u][i], dis[u]));
		u = getNext();
		if(u == end) return;
	}
}

int main() {
	// freopen("stdin.txt", "r", stdin);
	int i, j, cas = 1;
	while(scanf("%d", &n), n) {
		for(i = 0; i < n; ++i) {
			scanf("%d%d", &Stone[i].x, &Stone[i].y);
			for(j = 0; j < i; ++j)
				map[i][j] = map[j][i] = calDis(i, j);
			map[i][i] = 0.0;
		}
		Dijkstra(0, 1);
		printf("Scenario #%d\nFrog Distance = %.3lf\n\n", cas++, dis[1]);
	}
	return 0;
}


POJ2253 Frogger 【Dijkstra】

标签:poj2253

原文地址:http://blog.csdn.net/chang_mu/article/details/40155441

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!