码迷,mamicode.com
首页 > 其他好文 > 详细

1132 Cut Integer (20 分)

时间:2019-01-29 22:06:38      阅读:170      评论:0      收藏:0      [点我收藏+]

标签:using   out   contains   integer   dev   and   VID   cas   turn   

Cutting an integer means to cut a K digits lone integer Z into two integers of (K/2) digits long integers A and B. For example, after cutting Z = 167334, we have A = 167 and B = 334. It is interesting to see that Z can be devided by the product of A and B, as 167334 / (167 × 334) = 3. Given an integer Z, you are supposed to test if it is such an integer.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 20). Then N lines follow, each gives an integer Z (10 ≤ Z <). It is guaranteed that the number of digits of Z is an even number.

Output Specification:

For each case, print a single line Yes if it is such a number, or No if not.

Sample Input:

3
167334
2333
12345678

Sample Output:

Yes
No
No
思路:
  数字截断以后会出现0,提交是“浮点错误”。
#include<iostream>
#include<vector>
#include<algorithm>
#include<map>
#include<set>
#include<cmath>
#include<climits>
#include<sstream>
using namespace std;



int main()
{
    int n;
    scanf("%d",&n);
    for(int i=0;i<n;i++)
    {
        string temp;
        cin>>temp;
        int len=temp.size()/2;
        long long int a=stoi(temp.substr(0,len));
        long long int b=stoi(temp.substr(len));
        //cout<<a<<" "<<b<<endl;
        long long int x=stoi(temp);
        long long int c=x/a;
        if(a!=0&&b!=0&&x%(a*b)==0)
        {
          cout<<"Yes"<<endl;
        }
            
        else
            cout<<"No"<<endl;
    }
    return 0;
}

 

 

1132 Cut Integer (20 分)

标签:using   out   contains   integer   dev   and   VID   cas   turn   

原文地址:https://www.cnblogs.com/zhanghaijie/p/10335902.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!