码迷,mamicode.com
首页 > 其他好文 > 详细

HDOJ 5063 Operation the Sequence

时间:2014-10-17 11:59:41      阅读:135      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   io   os   ar   java   


注意到查询次数不超过50次,那么可以从查询位置逆回去操作,就可以发现它在最初序列的位置,再逆回去即可求得当前查询的值,对于一组数据复杂度约为O(50*n)。

Operation the Sequence

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 463    Accepted Submission(s): 187


Problem Description
You have an array consisting of n integers: a1=1,a2=2,a3=3,,an=n. Then give you m operators, you should process all the operators in order. Each operator is one of four types:
Type1: O 1 call fun1();
Type2: O 2 call fun2();
Type3: O 3 call fun3();
Type4: Q i query current value of a[i], this operator will have at most 50.
Global Variables: a[1…n],b[1…n];
fun1() {
index=1;
  for(i=1; i<=n; i +=2) 
    b[index++]=a[i];
  for(i=2; i<=n; i +=2)
    b[index++]=a[i];
  for(i=1; i<=n; ++i)
    a[i]=b[i];
}
fun2() {
  L = 1;R = n;
  while(L<R) {
    Swap(a[L], a[R]); 
    ++L;--R;
  }
}
fun3() {
  for(i=1; i<=n; ++i) 
    a[i]=a[i]*a[i];
}
 

Input
The first line in the input file is an integer T(1T20), indicating the number of test cases.
The first line of each test case contains two integer n(0<n100000)m(0<m100000).
Then m lines follow, each line represent an operator above.
 

Output
For each test case, output the query values, the values may be so large, you just output the values mod 1000000007(1e9+7).
 

Sample Input
1 3 5 O 1 O 2 Q 1 O 3 Q 1
 

Sample Output
2 4
 

Source
 



#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>

using namespace std;

typedef long long int LL;

const LL MOD=1000000007LL;

int n,m;
char op[10];
int p[110000],np;

LL quickpow(LL p,LL x)
{
    LL ret=1;
    LL e=p;
    while(x)
    {
        if(x%2LL) ret=(ret*e)%MOD;
        e=(e*e)%MOD;
        x/=2LL;
    }
    return ret%MOD;
}

LL query(int x)
{
    LL c=1;
	int pos=x;
    int half=(n+1)/2;
    for(int i=np-1;i>=0;i--)
    {
        if(p[i]==3) c=(c+c)%(MOD-1);
        else if(p[i]==2) pos=n-pos+1;
        else if(p[i]==1)
        {
            if(pos<=half) pos=2*(pos-1)+1;
            else pos=(pos-half)*2;
        }
    }
    return quickpow((LL)pos,c);
}

int main()
{
    int T_T;
    scanf("%d",&T_T);
    while(T_T--)
    {
        np=0;
        scanf("%d%d",&n,&m);
        for(int i=0;i<m;i++)
        {
            int x;
            scanf("%s%d",op,&x);
            if(op[0]=='O') p[np++]=x;
            else if(op[0]=='Q') printf("%I64d\n",query(x));
        }
    }
    return 0;
}



HDOJ 5063 Operation the Sequence

标签:des   style   blog   http   color   io   os   ar   java   

原文地址:http://blog.csdn.net/ck_boss/article/details/40182657

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!