码迷,mamicode.com
首页 > 其他好文 > 详细

POJ2689 ZOJ1842 UVA10140 Prime Distance【筛选法】

时间:2019-02-13 00:25:11      阅读:153      评论:0      收藏:0      [点我收藏+]

标签:other   zoj   pos   and   iss   http   printf   exce   pairs   

Prime Distance
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 25099 Accepted: 6567

Description

The branch of mathematics called number theory is about properties of numbers. One of the areas that has captured the interest of number theoreticians for thousands of years is the question of primality. A prime number is a number that is has no proper factors (it is only evenly divisible by 1 and itself). The first prime numbers are 2,3,5,7 but they quickly become less frequent. One of the interesting questions is how dense they are in various ranges. Adjacent primes are two numbers that are both primes, but there are no other prime numbers between the adjacent primes. For example, 2,3 are the only adjacent primes that are also adjacent numbers.
Your program is given 2 numbers: L and U (1<=L< U<=2,147,483,647), and you are to find the two adjacent primes C1 and C2 (L<=C1< C2<=U) that are closest (i.e. C2-C1 is the minimum). If there are other pairs that are the same distance apart, use the first pair. You are also to find the two adjacent primes D1 and D2 (L<=D1< D2<=U) where D1 and D2 are as distant from each other as possible (again choosing the first pair if there is a tie).

Input

Each line of input will contain two positive integers, L and U, with L < U. The difference between L and U will not exceed 1,000,000.

Output

For each L and U, the output will either be the statement that there are no adjacent primes (because there are less than two primes between the two given numbers) or a line giving the two pairs of adjacent primes.

Sample Input

2 17
14 17

Sample Output

2,3 are closest, 7,11 are most distant.
There are no adjacent primes.

Source

Waterloo local 1998.10.17

问题链接POJ2689 ZOJ1842 UVA10140 Prime Distance
问题简述:(略)
问题分析
????求[l,r]区间内最近和最远的素数对。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C++语言程序如下:

/* POJ2689 ZOJ1842 UVA10140 Prime Distance */

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>

using namespace std;

const long long SUP = 0x7FFFFFFFFFFFFFFF;
const int N = 100005;
bool vis[N * 10];
int primek[N / 10], pcnt;

int main()
{
    memset(vis, false, sizeof(vis));
    for (long long i = 2; i < N; i++) {
        if (vis[i]) continue;
        primek[pcnt++] = i;
        for (long long j = i * i; j < N; j += i)
            vis[j] = true;
    }

    long long l, r;
    while (~scanf("%lld%lld", &l, &r)) {
        memset(vis, 0, sizeof(vis));
        for (long long i = 0; i < pcnt; i++)
            for (long long j = ((l + primek[i] - 1) / primek[i]) * primek[i]; j <= r; j += primek[i])
                if (j / primek[i] != 1)
                    vis[j - l] = 1;

        long long pre = -1;
        long long maxv = 0, minv = SUP;
        long long maxl, maxr, minl, minr, flag = 1;
        for (long long i = l; i <= r; i++) {
            if (vis[i - l] || i == 1) continue;
            if (pre != -1) {
                if (i - pre > maxv) {
                    maxv = i - pre;
                    maxl = pre;
                    maxr = i;
                }
                if (i - pre < minv) {
                    minv = i - pre;
                    minl = pre;
                    minr = i;
                }
                flag = 0;
            }
            pre = i;
        }
        if (flag)
            printf("There are no adjacent primes.\n");
        else
            printf("%lld,%lld are closest, %lld,%lld are most distant.\n", minl, minr, maxl, maxr);
    }
    return 0;
}

POJ2689 ZOJ1842 UVA10140 Prime Distance【筛选法】

标签:other   zoj   pos   and   iss   http   printf   exce   pairs   

原文地址:https://www.cnblogs.com/tigerisland45/p/10367539.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!