码迷,mamicode.com
首页 > 其他好文 > 详细

UVA 1619 Feel Good(DP)

时间:2014-10-17 21:59:29      阅读:229      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   color   io   os   ar   for   strong   

Bill is developing a new mathematical theory for human emotions. His recent investigations are dedicated to studying how good or bad days influent people‘s memories about some period of life.

A new idea Bill has recently developed assigns a non-negative integer value to each day of human life. Bill calls this value the emotional value of the day. The greater the emotional value is, the better the day was. Bill suggests that the value of some period of human life is proportional to the sum of the emotional values of the days in the given period, multiplied by the smallest emotional value of the day in it. This schema reflects that good on average period can be greatly spoiled by one very bad day.

Now Bill is planning to investigate his own life and find the period of his life that had the greatest value. Help him to do so.

Input 

The input will contain several test cases, each of them as described below. Consecutive test cases are separated by a single blank line.


The first line of the input file contains n - the number of days of Bill‘s life he is planning to investigate (1bubuko.com,布布扣nbubuko.com,布布扣100000) . The rest of the file contains n integer numbers a1a2,..., an ranging from 0 to 106 - the emotional values of the days. Numbers are separated by spaces and/or line breaks.

Output 

For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line.


On the first line of the output file print the greatest value of some period of Bill‘s life.

On the second line print two numbers l and r such that the period from l -th to r -th day of Bill‘s life (inclusive) has the greatest possible value. If there are multiple periods with the greatest possible value, then print the shortest one. If there are still several possibilities, print the one that occurs first..

Sample Input 

6 
3 1 6 4 5 2

Sample Output 

60 

3 5

题意:选取连续的几天,求区间中最小的值*区间值的和的最大值:

ps:大家去POJ交吧,UVA这道题坑死人

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<limits.h>
typedef long long LL;
using namespace std;
const int maxn=1000010;
int l[maxn],r[maxn];
LL sum[maxn],dp[maxn];
int main()
{
   int n;
   int cas=0;
   while(~scanf("%d",&n))
   {
       memset(sum,0,sizeof(sum));
       if(cas)
          puts("");
       cas++;
       for(int i=1;i<=n;i++)
       {
           scanf("%lld",&dp[i]);
           sum[i]=sum[i-1]+dp[i];
           l[i]=r[i]=i;
       }
//       cout<<"23333  "<<endl;
       for(int i=1;i<=n;i++)
       {
           if(dp[i]>0)
           {
               while(dp[l[i]-1]>=dp[i])
                  l[i]=l[l[i]-1];
           }
       }
//       cout<<"hahahah  "<<endl;
       for(int i=n;i>=1;i--)
       {
           if(dp[i]>0)
           {
               while(dp[r[i]+1]>=dp[i])
                  r[i]=r[r[i]+1];
           }
       }
//       cout<<"111  "<<endl;
       LL ans=0,temp;
       int ll=1,rr=1;
       for(int i=1;i<=n;i++)
       {
//           cout<<"fuck  "<<endl;
           if(dp[i]>0)
           {
               temp=dp[i]*(sum[r[i]]-sum[l[i]-1]);
               if(temp>ans)
               {
                   ans=temp;
                   ll=l[i];
                   rr=r[i];
               }
               else  if(temp==ans)
               {
                   if(rr-ll==r[i]-l[i]&&l[i]<ll)
                   {
                       ll=l[i];
                       rr=r[i];
                   }
               }
           }
       }
       printf("%lld\n%d %d\n",ans,ll,rr);
   }
   return 0;
}


UVA 1619 Feel Good(DP)

标签:des   style   http   color   io   os   ar   for   strong   

原文地址:http://blog.csdn.net/u013582254/article/details/40191549

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!