码迷,mamicode.com
首页 > 其他好文 > 详细

SDNU 1331.Kick Veges' Ass(二分法)

时间:2019-02-24 21:30:25      阅读:209      评论:0      收藏:0      [点我收藏+]

标签:ant   algo   sdn   cst   else   大于   pre   input   answer   

Description

There are n veges stand in line, Albert_s plan to punish them since they are too weak. The picture following below shows one of the veges waiting to be kicked.
 

Now Albert_s plan to kick all the veges on days in order. Since Kick the vege costs him RP, and the final cost is equal to the max cost of one day on the days.

Albert_s wants to minimize the final cost, so how much RP he costs by following the rule above?

Input

The first line contains two integer ;

The second line contains space-separated integers , the elements of the array.

,,?

Output

A number indicating the answer.

Sample Input

5 2
2 1 3 4 5

Sample Output

9

Hint

Another vege is waiting to be kicked.
 
End:
 
#include <cstdio>
#include <iostream>
#include <cmath>
#include <string>
#include <cstring>
#include <algorithm>
#include <queue>

using namespace std;

#define ll long long

const int maxn = 1e5+100;
int a[maxn];
int n, m;

bool c(ll x)
{
    ll cnt = 1, sum = 0;
    for(int i = 0; i<n;)
    {
        if(x >= sum+a[i])//用二分的方法来不断把菜的屁股一段一段踢掉
        {
            sum += a[i];
//            printf("i = %d, sum = %lld\n",i,  sum);
            i++;
        }
        else
        {
            sum = 0;//那一天不能踢那么多屁股,就从新的一天开始
            cnt++;//统计天数目
//            printf("sum = %lld, cnt = %lld\n", sum, cnt);
            if(cnt>m)return 0;//如果天数大于输入的天数,则返回0
        }
    }
    return cnt <= m;//必须要二分的结果小于输入的天数
}
int main()
{
    scanf("%d%d", &n, &m);
    for(int i = 0; i<n; i++)
    {
        scanf("%d", &a[i]);
    }
    ll lb = 0, ub = 1e14;
//    printf("lb = %lld, ub = %lld\n", lb, ub);
    while(ub>lb)
    {
        ll mid  = (lb+ub)/2;
        if(c(mid))ub = mid;
        else lb = mid +1;//之前的一个已经遍历过了,从下一个开始
//        printf("lb = %lld, ub = %lld\n", lb, ub);
    }
    printf("%lld\n", ub);
    return 0;
}

 

SDNU 1331.Kick Veges' Ass(二分法)

标签:ant   algo   sdn   cst   else   大于   pre   input   answer   

原文地址:https://www.cnblogs.com/RootVount/p/10427965.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!