码迷,mamicode.com
首页 > 其他好文 > 详细

Catch That Cow (BFS广搜)

时间:2019-03-07 14:17:52      阅读:162      评论:0      收藏:0      [点我收藏+]

标签:wal   not   代码   orm   reac   john   str   string   poi   

问题描述:

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

解题思路:

bfs,三个方向搜索,x=x+1,x=x-1,x=x*2,最先搜索到的就是用时最短的。

代码:

#include<cstdio>
#include<queue>
#include<cstring>
#include<iostream>
using namespace std;
int n,k;
int a[100010];

struct node
{
    int x;
    int step;
}now,net;

int bfs(int x)
{
    queue<node> q;
    now.x=x;
    now.step=0;
    q.push(now);
    while(q.size())
    {
        now=q.front();
        q.pop();
        //三种情况
        if(now.x==k)return now.step;
        net.x=now.x+1;
        if(net.x>=0&&net.x<=100000&&a[net.x]==0)
        {
            a[net.x]=1;
            net.step=now.step+1;
            q.push(net);
        }
        net.x=now.x-1;
        if(net.x>=0&&net.x<=100000&&a[net.x]==0)
        {
            a[net.x]=1;
            net.step=now.step+1;
            q.push(net);
        }
        net.x=now.x*2;
        if(net.x>=0&&net.x<=100000&&a[net.x]==0)
        {
            a[net.x]=1;
            net.step=now.step+1;
            q.push(net);
        }
    }
    return -1;
}

int main()
{
    while(~scanf("%d%d",&n,&k))
    {
        memset(a,0,sizeof(a));
        a[n]=1;
        int ans=bfs(n);
        printf("%d\n",ans);
    }
    return 0;
}

 

Catch That Cow (BFS广搜)

标签:wal   not   代码   orm   reac   john   str   string   poi   

原文地址:https://www.cnblogs.com/boboyuzz/p/10489166.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!