码迷,mamicode.com
首页 > 其他好文 > 详细

Digital Roots:高精度

时间:2019-03-17 19:39:55      阅读:179      评论:0      收藏:0      [点我收藏+]

标签:blank   题目   string   names   input   list   its   +=   ==   

C - Digital Roots

Description

The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

Input

The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.

Output

For each integer in the input, output its digital root on a separate line of the output.

Sample Input

24
39
0

Sample Output

6
3

题目描述:多组输入,输入n,把n的每一位加起来,求出新的n来,不断地加,直到n小于10.用到九余定理。

#include<iostream>
#include<string>
using namespace std;
int main() {
	string s;
	while (cin>>s) {
		int ans = 0;
		int lens = s.size();
		for (int i = 0; i < lens; i++) {
			ans += s[i] - ‘0‘;
		}
		if (ans == 0)break;
		else
			cout << (ans- 1) % 9 + 1 << endl;		//九余定理 
	}
	return 0;
}

/*
设x是一个四位数 
x=a*1000+b*100+c*10+d	=>	x=a*999+b*99+c*9+d+a+b+c	=>要求a+b+c+d 即求 (a*999+b*99+c*9+d+a+b+c)%9即可, 即求x%9 
特例x==9时,,所以先-1,取余9后再+1 
 例如45=4+5=9
 如果9%9==0		但是结果是0		 
*/ 

 

Digital Roots:高精度

标签:blank   题目   string   names   input   list   its   +=   ==   

原文地址:https://www.cnblogs.com/52dxer/p/10548305.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!