码迷,mamicode.com
首页 > 其他好文 > 详细

LightOJ - 1422 Halloween Costumes(区间dp)

时间:2019-04-14 17:54:49      阅读:159      评论:0      收藏:0      [点我收藏+]

标签:ase   clean   cstring   ken   iostream   ast   img   any   pre   

Gappu has a very busy weekend ahead of him. Because, next weekend is Halloween, and he is planning to attend as many parties as he can. Since it‘s Halloween, these parties are all costume parties, Gappu always selects his costumes in such a way that it blends with his friends, that is, when he is attending the party, arranged by his comic-book-fan friends, he will go with the costume of Superman, but when the party is arranged contest-buddies, he would go with the costume of ‘Chinese Postman‘.

技术图片

Since he is going to attend a number of parties on the Halloween night, and wear costumes accordingly, he will be changing his costumes a number of times. So, to make things a little easier, he may put on costumes one over another (that is he may wear the uniform for the postman, over the superman costume). Before each party he can take off some of the costumes, or wear a new one. That is, if he is wearing the Postman uniform over the Superman costume, and wants to go to a party in Superman costume, he can take off the Postman uniform, or he can wear a new Superman uniform. But, keep in mind that, Gappu doesn‘t like to wear dresses without cleaning them first, so, after taking off the Postman uniform, he cannot use that again in the Halloween night, if he needs the Postman costume again, he will have to use a new one. He can take off any number of costumes, and if he takes off k of the costumes, that will be the last k ones (e.g. if he wears costume A before costume B, to take off A, first he has to remove B).

Given the parties and the costumes, find the minimum number of costumes Gappu will need in the Halloween night.

Input

Input starts with an integer T (≤ 200), denoting the number of test cases.

Each case starts with a line containing an integer N (1 ≤ N ≤ 100) denoting the number of parties. Next line contains Nintegers, where the ith integer ci (1 ≤ ci ≤ 100) denotes the costume he will be wearing in party i. He will attend party 1 first, then party 2, and so on.

Output

For each case, print the case number and the minimum number of required costumes.

Sample Input

2

4

1 2 1 2

7

1 2 1 1 3 2 1

Sample Output

Case 1: 3

Case 2: 4

题意:按顺序去参加舞会。每个舞会对衣服都有要求。可以连续穿好多件衣服。需要时候就脱下来,但是一旦脱下来,这件衣服就报废了。问最少需要几件衣服。

思路:dp[][]表示i~j这个区间最少需要几件衣服,我觉得这道题的关键除了再理解是区间dp以外 就是初始化了 对于一个区间i~j来说 如果 a[i]==a[j] 显然dp[i][j]=dp[i][j-1];

然后枚举分割点 如果a[i]==a[k] 那么就看看是不是 dp[i][k]+dp[k+1][j]更优 如果是就更新

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<string>
#include<vector>
#include<stack>
#include<bitset>
#include<cstdlib>
#include<cmath>
#include<set>
#include<list>
#include<deque>
#include<map>
#include<queue>
#define ll long long int
using namespace std;
inline ll gcd(ll a,ll b){return b?gcd(b,a%b):a;}
inline ll lcm(ll a,ll b){return a/gcd(a,b)*b;}
int moth[13]={0,31,28,31,30,31,30,31,31,30,31,30,31};
int dir[4][2]={1,0 ,0,1 ,-1,0 ,0,-1};
int dirs[8][2]={1,0 ,0,1 ,-1,0 ,0,-1, -1,-1 ,-1,1 ,1,-1 ,1,1};
const int inf=0x3f3f3f3f;
const ll mod=1e9+7;
int dp[107][107];
int a[107];
int main(){
    ios::sync_with_stdio(false);
    int t;
    cin>>t;
    int w=0;
    while(t--){
        memset(dp,inf,sizeof(dp)); 
        int n; cin>>n;
        for(int i=1;i<=n;i++){
            cin>>a[i];
            dp[i][i]=1; //i~i的区间的解只能是1 不会更优 
        }
        for(int len=2;len<=n;len++)
            for(int i=1;i+len<=n+1;i++){
                int j=i+len-1;
                if(a[i]==a[j]) dp[i][j]=dp[i][j-1]; //更新更优解 
                for(int k=i;k<j;k++)
                    if(a[k]==a[i])
                    dp[i][j]=min(dp[i][j],dp[i][k]+dp[k+1][j]); //找前面的小区间最优解到达该区间是否更优 
            }
        cout<<"Case "<<++w<<": ";
        cout<<dp[1][n]<<endl;
    } 
    return 0;
}

 

LightOJ - 1422 Halloween Costumes(区间dp)

标签:ase   clean   cstring   ken   iostream   ast   img   any   pre   

原文地址:https://www.cnblogs.com/wmj6/p/10705884.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!