码迷,mamicode.com
首页 > 其他好文 > 详细

PAT 1126 Eulerian Path

时间:2019-05-04 14:43:55      阅读:113      评论:0      收藏:0      [点我收藏+]

标签:wrap   int   连通   The   describes   pat   content   重复   路径   

1126 Eulerian Path (25 分)
 

In graph theory, an Eulerian path is a path in a graph which visits every edge exactly once. Similarly, an Eulerian circuit is an Eulerian path which starts and ends on the same vertex. They were first discussed by Leonhard Euler while solving the famous Seven Bridges of Konigsberg problem in 1736. It has been proven that connected graphs with all vertices of even degree have an Eulerian circuit, and such graphs are called Eulerian. If there are exactly two vertices of odd degree, all Eulerian paths start at one of them and end at the other. A graph that has an Eulerian path but not an Eulerian circuit is called semi-Eulerian. (Cited from https://en.wikipedia.org/wiki/Eulerian_path)

Given an undirected graph, you are supposed to tell if it is Eulerian, semi-Eulerian, or non-Eulerian.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N (≤ 500), and M, which are the total number of vertices, and the number of edges, respectively. Then M lines follow, each describes an edge by giving the two ends of the edge (the vertices are numbered from 1 to N).

Output Specification:

For each test case, first print in a line the degrees of the vertices in ascending order of their indices. Then in the next line print your conclusion about the graph -- either EulerianSemi-Eulerian, or Non-Eulerian. Note that all the numbers in the first line must be separated by exactly 1 space, and there must be no extra space at the beginning or the end of the line.

Sample Input 1:

7 12
5 7
1 2
1 3
2 3
2 4
3 4
5 2
7 6
6 3
4 5
6 4
5 6

Sample Output 1:

2 4 4 4 4 4 2
Eulerian

Sample Input 2:

6 10
1 2
1 3
2 3
2 4
3 4
5 2
6 3
4 5
6 4
5 6

Sample Output 2:

2 4 4 4 3 3
Semi-Eulerian

Sample Input 3:

5 8
1 2
2 5
5 4
4 1
1 3
3 2
3 4
5 3

Sample Output 3:

3 3 4 3 3
Non-Eulerian

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
#define MAXN 10005

int n,m;
int a[MAXN] = {0};
int vis[MAXN] = {0};
set<pair<int,int>> st;
vector<vector<int>>vec;

void dfs(int x){
    vis[x] = 1;
    for(int i=0;i < vec[x].size();i++){
        if(!vis[vec[x][i]]){
            dfs(vec[x][i]);
        }
    }
}





int main(){
    cin >> n >> m;
    vec.resize(n+1);
    for(int i=0;i < m;i++){
        int x,y;
        cin >> x >> y;
        a[x]++;a[y]++;
        vec[x].push_back(y);
        vec[y].push_back(x);
    }
    int cntodd = 0;
    for(int i=1;i <= n;i++){
        cout << a[i];
        if(i!=n) cout << " ";
        if(a[i]%2)cntodd++;
    }
    cout << endl;

    dfs(1);
    int flag = 0;
    for(int i=1;i <= n;i++){
        if(!vis[i])flag = 1;
    }
    if(flag){
        cout <<"Non-Eulerian";
        return 0;
    }








    if(!cntodd) cout << "Eulerian";
    else{
        if(cntodd == 2) cout << "Semi-Eulerian";
        else cout << "Non-Eulerian";
    }
    return 0;
}

题目大意:欧拉图就是能一笔画的图,如果度数都为偶数就是欧拉环路,如果有两个奇数度数就不是环路但还是能一笔画。

在检验度数前要先判断是否是连通图,还好这题没有给重复的路径。。

PAT 1126 Eulerian Path

标签:wrap   int   连通   The   describes   pat   content   重复   路径   

原文地址:https://www.cnblogs.com/cunyusup/p/10808284.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!