码迷,mamicode.com
首页 > 其他好文 > 详细

poj 1915 Knight Moves 【双向bfs】

时间:2014-10-21 13:50:55      阅读:121      评论:0      收藏:0      [点我收藏+]

标签:双向bfs

Knight Moves
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 22121   Accepted: 10332

Description

Background 
Mr Somurolov, fabulous chess-gamer indeed, asserts that no one else but him can move knights from one position to another so fast. Can you beat him? 
The Problem 
Your task is to write a program to calculate the minimum number of moves needed for a knight to reach one point from another, so that you have the chance to be faster than Somurolov. 
For people not familiar with chess, the possible knight moves are shown in Figure 1. 
bubuko.com,布布扣

Input

The input begins with the number n of scenarios on a single line by itself. 
Next follow n scenarios. Each scenario consists of three lines containing integer numbers. The first line specifies the length l of a side of the chess board (4 <= l <= 300). The entire board has size l * l. The second and third line contain pair of integers {0, ..., l-1}*{0, ..., l-1} specifying the starting and ending position of the knight on the board. The integers are separated by a single blank. You can assume that the positions are valid positions on the chess board of that scenario.

Output

For each scenario of the input you have to calculate the minimal amount of knight moves which are necessary to move from the starting point to the ending point. If starting point and ending point are equal,distance is zero. The distance must be written on a single line.

Sample Input

3
8
0 0
7 0
100
0 0
30 50
10
1 1
1 1

Sample Output

5
28
0

分析:最基础的bfs,没用单向的广搜,学习了一下怎么用双向的广搜。

以下仅个人观点。。。

能用到双向广搜的题,首先得有开始点和目标点,然后就是从开始和目标同时出发,分别进行单向搜索,知道某一方向的搜索碰到另一方向搜索过得点为止。。

#include <stdio.h>
#include <queue>
#include <string.h>
#define  M 305
using namespace std;

int dis1[M][M], dis2[M][M], len;
const int dx[] = {1, 1, -1, -1, 2, 2, -2, -2};  //方向
const int dy[] = {2, -2, 2, -2, 1, -1, 1, -1};
struct node{
    int x, y;
}st, en;


int limit(node a){
    return (a.x>=0&&a.x<len&&a.y>=0&&a.y<len);
}

void dobfs(){
   int i, size;
   dis1[st.x][st.y] = dis2[en.x][en.y] = 0;
   queue<node> p, q;
   q.push(st); p.push(en);
   while(!q.empty()&&!p.empty()){
        size = q.size();
        while(size --){  
            node cur = q.front();
            q.pop();
            if(limit(cur)&&dis2[cur.x][cur.y] != -1){
                //printf("%d %d..1\n", dis1[cur.x][cur.y], dis2[cur.x][cur.y]);
                printf("%d\n", dis1[cur.x][cur.y]+dis2[cur.x][cur.y]);
                return ;
            }
            for(i = 0; i < 8; i ++){
                node temp = cur;
                temp.x+=dx[i], temp.y += dy[i];
                if(limit(temp)&&dis2[temp.x][temp.y] != -1){
                     //printf("%d %d....1\n", dis1[cur.x][cur.y], dis2[temp.x][temp.y]);
                    printf("%d\n", dis1[cur.x][cur.y]+dis2[temp.x][temp.y]+1);
                    return ;
                }
                if(limit(temp)&&dis1[temp.x][temp.y] == -1){
                    q.push(temp); dis1[temp.x][temp.y] = dis1[cur.x][cur.y]+1;
                }
            }
        }
        size = p.size();
        while(size --){
            node cur = p.front();
            p.pop();
            if(limit(cur)&&dis1[cur.x][cur.y] != -1){
                 //printf("%d %d..2\n", dis1[cur.x][cur.y], dis2[cur.x][cur.y]);
                printf("%d\n", dis1[cur.x][cur.x]+dis2[cur.x][cur.y]);
                return ;
            }
            for(i = 0; i < 8; i ++){
                node temp = cur;
                temp.x += dx[i]; temp.y += dy[i];
                if(limit(temp)&&dis1[temp.x][temp.y] != -1){
                     //printf("%d %d....2\n", dis2[cur.x][cur.y], dis1[temp.x][temp.y]);
                    printf("%d\n", dis1[temp.x][temp.y]+dis2[cur.x][cur.y]+1);
                    return ;
                }
                if(limit(temp)&&dis2[temp.x][temp.y] == -1){
                    p.push(temp); dis2[temp.x][temp.y] = dis2[cur.x][cur.y] + 1;
                }
            }
        }
   }
}

int main(){
    int t;
    scanf("%d", &t);
    while(t --){
        scanf("%d", &len);
        scanf("%d%d%d%d", &st.x, &st.y, &en.x, &en.y);
        memset(dis1, -1, sizeof(dis1));
        memset(dis2, -1, sizeof(dis2));
        if(match(st, en)){
            printf("0\n"); continue;
        }
        else   dobfs();
    }
    return 0;
}



poj 1915 Knight Moves 【双向bfs】

标签:双向bfs

原文地址:http://blog.csdn.net/shengweisong/article/details/40343477

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!