码迷,mamicode.com
首页 > 其他好文 > 详细

[POJ3904]Sky Code

时间:2019-06-21 12:59:59      阅读:70      评论:0      收藏:0      [点我收藏+]

标签:list   like   就是   image   ted   void   from   any   which   

[POJ3904]Sky Code

题面

Stancu likes space travels but he is a poor software developer and will never be able to buy his own spacecraft. That is why he is preparing to steal the spacecraft of Petru. There is only one problem – Petru has locked the spacecraft with a sophisticated cryptosystem based on the ID numbers of the stars from the Milky Way Galaxy. For breaking the system Stancu has to check each subset of four stars such that the only common divisor of their numbers is 1. Nasty, isn’t it? Fortunately, Stancu has succeeded to limit the number of the interesting stars to N but, any way, the possible subsets of four stars can be too many. Help him to find their number and to decide if there is a chance to break the system.

Input

In the input file several test cases are given. For each test case on the first line the number N of interesting stars is given (1 ≤ N ≤ 10000). The second line of the test case contains the list of ID numbers of the interesting stars, separated by spaces. Each ID is a positive integer which is no greater than 10000. The input data terminate with the end of file.

Output

For each test case the program should print one line with the number of subsets with the asked property.

Sample Input

4
2 3 4 5 
4
2 4 6 8 
7
2 3 4 5 7 6 8

Sample Output

1 
0 
34

思路

考虑到若四个数互质,那么\(gcd(a,b,c,d)=1\)统计这种情况比较难搞。那我们就可以用容斥来搞一搞,计算一下四个数不互质的情况有哪些。假设\(A\)包含所有\(gcd(a,b,c,d)\ne1\)的四元组。那么最后的答案就是\(C_n^4-\left | A\right |\)

那如何找到所有不互质的四元组呢?显然对于任何不互质的四元组,都存在一个包含他们所有公共质因子积的数\(d\),那么包含\(d\)的数的个数就记为\(cnt[d]\)。而这些数能组成的四元组的个数为\(C_{cnt[d]}^4\),把这些四元组的集合记作\(A_{cnt[d]}\)。但是还是有一个小问题,显然,有的四元组会被重复计算。

而容斥原理,简单来说就是把偶数个集合的交集减掉,把奇数个集合的交集加上。那么放到这道题来说,如果一个因数包含的质因子个数为偶数,就可以把它减掉。

代码

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstring>
using namespace std;
#define maxn 10500
#define ll long long
ll c[maxn];
int n,a[maxn],cnt[maxn],num[maxn];
void init(){
    for(ll i=4;i<=10500;i++){
        c[i]=i*(i-1)*(i-2)*(i-3)/24;
    }
}
void div(int x){
    int p=0,prime[100],tmp=x;
    for(int i=2;i<=sqrt(x);i++){
        if(tmp%i==0)prime[++p]=i;
        while(tmp%i==0)tmp/=i;
    }
    if(tmp>1)prime[++p]=tmp;
    for(int i=1;i<(1<<p);i++){
        int sum=0,tot=1;
        for(int j=0;j<p;j++){
            if(i&(1<<j)){
                sum++;tot*=prime[j+1];
            }
        }
        cnt[tot]++;
        num[tot]=sum;
    }
    return;
}
void solve(){
    memset(cnt,0,sizeof(cnt));
    memset(num,0,sizeof(num));
    memset(a,0,sizeof(a));
    for(int i=1;i<=n;i++){scanf("%d",&a[i]);div(a[i]);}
    ll ans=0;
    for(int i=2;i<=10050;i++){
        if(cnt[i]<4)continue;
        if(num[i]&1)ans+=c[cnt[i]];
        else ans-=c[cnt[i]];
    }
    printf("%lld\n",c[n]-ans);
    return;
}
int main(){
    init();
    while(~scanf("%d",&n))solve();
    return 0;
}

技术图片

[POJ3904]Sky Code

标签:list   like   就是   image   ted   void   from   any   which   

原文地址:https://www.cnblogs.com/GavinZheng/p/11063809.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!