码迷,mamicode.com
首页 > 其他好文 > 详细

pat 1012 The Best Rank

时间:2019-06-24 21:08:51      阅读:109      评论:0      收藏:0      [点我收藏+]

标签:text   names   begin   rate   ++   vector   input   include   diff   

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of CME and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of CM and E. Then there are M lines, each containing a student ID.

Output Specification:

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A C M E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

Sample Input:

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output:

1 C
1 M
1 E
1 A
3 A
N/A

Problem Solving:
For each subject, it needs to take a sort, and then traverse the sorted vector to find his minimun rank of this subject. Notice that if the ranks are same of same grades, and
the next rank of different grade is the position in the rank vector, for example, the grades are 97 95 95 90, and ranks are 1 2 2 4.

Code:
#include <iostream>
#include <string>
#include <vector>
#include <algorithm>
using namespace std;
struct Stu
{
    int id;
    int C, M, E, A;
};
bool CCmp(const Stu &s1, const Stu &s2)
{
    return s1.C > s2.C;
}
bool MCmp(const Stu &s1, const Stu &s2)
{
    return s1.M > s2.M;
}
bool ECmp(const Stu &s1, const Stu &s2)
{
    return s1.E > s2.E;
}
bool ACmp(const Stu &s1, const Stu &s2)
{
    return s1.A > s2.A;
}
int main()
{
    string na = "N/A";
    char names[] = {‘A‘, ‘C‘, ‘M‘, ‘E‘};
    int m, n, i;
    int a[2500];
    vector<Stu> stus;
    vector<Stu> CRank;
    vector<Stu> MRank;
    vector<Stu> ERank;
    vector<Stu> ARank;
    cin >> n >> m;
    Stu *s;
    for (i = 0; i < n; i++)
    {
        s = new Stu();
        cin >> s->id >> s->C >> s->M >> s->E;
        s->A = s->C + s->M + s->E;
        stus.push_back(*s);
    }
    Stu head = {200, 200, 200, 200, 400};
    stus.insert(stus.begin(), head);
    if (n == 0 || m == 0)
    {
        cout << na;
        return 0;
    }
    sort(stus.begin(), stus.end(), CCmp);
    CRank.assign(stus.begin(), stus.end());
    sort(stus.begin(), stus.end(), MCmp);
    MRank.assign(stus.begin(), stus.end());
    sort(stus.begin(), stus.end(), ECmp);
    ERank.assign(stus.begin(), stus.end());
    sort(stus.begin(), stus.end(), ACmp);
    ARank.assign(stus.begin(), stus.end());
    int size = stus.size(), min;
    int id;
    int num[4];
    char name;
    for (int j = 0; j < m; j++)
    {
        cin >> id;
        min = 3000;
        for (i = 0; i < 4; i++)
        {
            num[i] = 0;
        }
        //如果相等则排名不变,如果和之前的不等,则排名为当前i
        // 97 95 95 90 
        // 1  2  2  4
        for (i = 1; i < size; i++)
        {
            if (ARank[i].A != ARank[i - 1].A)
                num[0] = i;
            if (ARank[i].id == id)
            {
                break;
            }
        }
        if (i == size)
        {
            cout << na << endl;
            continue;
        }
        for (i = 1; i < size; i++)
        {
            if (CRank[i].C != CRank[i - 1].C)
                num[1] = i;
            if (CRank[i].id == id)
            {
                break;
            }
        }
        for (i = 1; i < size; i++)
        {
            if (MRank[i].M != MRank[i - 1].M)
                num[2] = i;
            if (MRank[i].id == id)
            {
                break;
            }
        }
        for (i = 1; i < size; i++)
        {
            if (ERank[i].E != ERank[i - 1].E)
                num[3] = i;
            if (ERank[i].id == id)
            {
                break;
            }
        }
        for (i = 0; i < 4; i++)
        {
            if (min > num[i])
            {
                min = num[i];
                name = names[i];
            }
        }
        cout << min << ‘ ‘ << name << endl;
    }
    return 0;
}

Impression:

Honestly, I have adpoted a not very good method to solve this problem, and I recommend the method in this blog, here is the link:https://blog.csdn.net/qq_24572475/article/details/82811274

 

pat 1012 The Best Rank

标签:text   names   begin   rate   ++   vector   input   include   diff   

原文地址:https://www.cnblogs.com/stormax/p/11079363.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!